Skip to Content.
Sympa Menu

grouper-users - RE: [grouper-users] bug in 1.2 rc3 with mysql 5

Subject: Grouper Users - Open Discussion List

List archive

RE: [grouper-users] bug in 1.2 rc3 with mysql 5

Chronological Thread 
  • From: "caleb racey" <>
  • To: <>
  • Subject: RE: [grouper-users] bug in 1.2 rc3 with mysql 5
  • Date: Tue, 19 Jun 2007 12:30:31 +0100

Short answer: It appears that getting the Mysql5 dialect in place does
not fix the problem.

Long answer: We are new to grouper and hibernate, while have experience
using ant are by no means gurus, so what follows may have something
stupid in it.

We recompiled the hibernate 2.1.8 jar and added the MySQL5 dialect to
it(it's not there by default). We did this by taking the out of the hibernate3 source changing the package
info at the top so it matches the hibernate2 package (net.sf.... instead
of org.hibernate....) and rebuilding with ant. We then put this
hibernate jar in the grouper lib directory, delete the old jar, ant
clean and delete the build directory

Configure Mysql5 via our build properties

hibernate.dialect = net.sf.hibernate.dialect.MySQL5Dialect

rebuild with ant

unfortunately we still get our problem sql for creating the grouper
attributes table

create table grouper_attributes (
id varchar(128) not null,
group_id varchar(128),
field_name varchar(32) not null,
value text not null,
primary key (id),
unique (group_id, field_name, value)

Which fails to create the table.

I'm not sure Mysql5 dialect would fix the problem it extenda the mysql
dialect we used before, the source is:

registerColumnType( Types.VARCHAR, "longtext" );
registerColumnType( Types.VARCHAR, 16777215, "mediumtext" );
registerColumnType( Types.VARCHAR, 65535, "varchar($l)" );

which doesn't mention a string type, however we don't have a lot of
experience of using hibernate so I may be missing something.

The work around is to hand create the table with workable sql as we did

Any thoughts?

>-----Original Message-----
>Behalf Of blair christensen.
>Sent: 18 June 2007 15:03
>To: caleb racey;
>Subject: Re: [grouper-users] bug in 1.2 rc3 with mysql 5
>Strange. The Hibernate schema files define "value" to be a string
>with a length of 1024. On the systems that I test on that becomes a
>"varchar(1024)" in the actual database schema.
>Tom's suggestion of checking your Hibernate dialect would be a good
>place to look first. If not there may be a Hibernate2/MySQL5 dialect
>incompatibility that will need to be worked around.

Archive powered by MHonArc 2.6.16.

Top of Page