Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] Trying to get QuickStart working

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] Trying to get QuickStart working

Chronological Thread 
  • From: "GW Brown, Information Systems and Computing" <>
  • To: Curt Blank <>
  • Cc: Grouper Users <>
  • Subject: Re: [grouper-users] Trying to get QuickStart working
  • Date: Thu, 25 Jan 2007 10:23:51 +0000

I also managed to get the WAR to work. I modified the, like Tom, started up an existing QuickStart database and then started up Tomcat. Everything worked as expected - which suggests that the build is OK, and that the problem probably lies with Tomcat - but without any errors in the logs that may be difficult to track down.

Is this a Tomcat instance you have installed, or was it set up by someone else and are other webapps deployed to it?

At this point I would normally attach a Java debugger to Tomcat and try to catch an Exception, however, it sounds like that is something you won't have done before.

I have attached a jsp which you can use to overwrite the one expanded from the WAR in WEB-INF/jsp. It should capture any Exception thrown at initialisation and print a stacktrace to the screen. Please send me the actual page source. Hopefully that will give a clue as to what is happening.


--On 23 January 2007 15:37 -0600 Tom Barton

I dropped your war file into my tomcat 5.5 webapps folder, restarted
tomcat, substituted sources.xml and for my
own (which point to my prototype sources and groups registry, not the
quickstart ones) and changed the pathnames in to point
to someplace that exists in my file system. Restarted tomcat again, and
it works fine.

Not sure what to conclude, but perhaps that helps you to focus your
search for the trouble.


Curt Blank wrote:
At first I thought I was on to something when you asked for the war file
and I didn't have one, so I made one, but it acts the same. I did the
dist and copied everything from the dist/grouper directory to
webapps/grouper. Now that I have a war file I see when I start tomcat it
creates and populates the webapps/grouper directory itself.

I seem to have made some head way though. I am not running apache
anymore during this endeavor.

I think I'm starting to understand some things, I got this:

HTTP Status 404 - /grouper/index.jsp


*type* Status report

*message* _/grouper/index.jsp_

*description* _The requested resource (/grouper/index.jsp) is not


Apache Tomcat/5.5.20

When neither the grouper.war file nor the webapps/grouper copied from
the dist existed. So that the fact I didn't get that when I did the dist
says it was sort of working. So now by the fact I'm getting a blank
screen says it's trying to work.

I've included my .war file which I am now using. (gzip'ing it didn't
help much so I didn't.)


Curt Blank wrote:

Sorry, meant to answer these questions.

> What versions of Java, Ant and Tomcat are you using?

Java jdk-1.5.0_10-fcs
Ant 1.7.0
Tomcat 5.5.20

> Do you get any error in the Tomcat logs e.g. catlina.out?

No, nothing.


Curt Blank wrote:

Thank you for this! Very informative. Gives me a path to go down, I
will give it all a try.


GW Brown, Information Systems and Computing wrote:

--On 22 January 2007 15:09 -0600 Curt Blank

I'm trying to get QuickStart working and this is frustrating. I
follow the instructions provided but I can't get it to work. I am no
java or tomcat expert so that probably has a lot to do with it.

What versions of Java, Ant and Tomcat are you using?

It seems to be doing something I connect to
and it takes me to http://localhost:8080/grouper/ but
then I get a white screen and a Done. I look at the page source and I
have this:

<?xml version="1.0" encoding="iso-8859-1"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"


<html xmlns=""; lang="en-US"


Do you get any error in the Tomcat logs e.g. catlina.out?

In httpd.conf I put this:

# <IfModule \!mod_jk.c>
LoadModule jk_module modules/
# </IfModule>
# JkWorkersFile "/usr/local/tomcat/conf/jk/"
JkLogFile "/var/log/httpd/mod_jk.log"
JkLogLevel emerg
JkMount /grouper/* ajp13

I had to comment out the IfModule(s) otherwise it wouldn't load.
And if I
don't comment out 'JkWorkersFile
"/usr/local/tomcat/conf/jk/"' apache won't start. I
don't know if I need that for QuickStart but the instructions don't
address it either way and if I need a where does
it come from?

In a production environment it is quite likely you would place
Apache in front of Tomcat and use mod_jk, however, in order to get
the QuickStart to work you don't need to do anything with Apache or
mod_jk - you can connect to Tomcat directly.

I'm also still getting this when I try to stop HSQLDB:

[java] Exception in thread "HSQLDB Connection @1b543c88"
java.lang.OutOfMemoryError: Java heap space

This is a direct consequence of using Telnet to shutdown the
database. I've never tried doing it this way before.

The QuickStart build file also has a 'dbgui' target which will load
a simple database manager ui which lets you query the database, and
also shut it down. If you can't do this directly on the machine
where the database is installed i.e. no X windows capability, you
can connect from a 'desktop' machine by changing the localhost in
the URL below:

<java dir="." classname="org.hsqldb.util.DatabaseManager"
classpathref="db.class.path" fork="true">
<arg line="-url jdbc:hsqldb:hsql://localhost:9001"/>

This is all extremely frustrating when you follow the instructions
and it
doesn't work. Granted being unfamiliar with java and tomcat doesn't
and I think I have the jk connector installed properly, but the
instructions should take this into account that people not familiar
all these components will be asked to install this.

I hear your frustration, and the QuickStart is supposed to make it
easy to get started specifically to avoid such frustration - and it
generally seems to achieve this.

If there is no error in the Tomcat log, I will try and come up with
a 'patch' which will produce some diagnostic output. It looks like
the error is occurring during initialisation before any Grouper /
Subject API calls are made.

In addition you could send me your WAR file + the contents of
grouper-qs/grouper/conf and I'll take a look at them to see if I can
spot anything.

-Curt Blank

GW Brown, Information Systems and Computing

GW Brown, Information Systems and Computing
<%-- @annotation@ Ensures that session is initialised with ResourceBundles. May be called even when not needed - so must review --%><%-- @author Gary Brown. @version $Id: initPreLoginSession.jsp,v 1.2 2006/10/05 09:07:38 isgwb Exp $ --%> <%@include file="/WEB-INF/jsp/include.jsp"%> <% try { if(Boolean.TRUE.equals(session.getAttribute("sessionInited"))) return; %> <% org.apache.struts.config.ModuleConfig config1 = (org.apache.struts.config.ModuleConfig) request.getAttribute("org.apache.struts.action.MODULE"); %> <% String module = config1.getPrefix(); %> <% //if(0==0) throw new IllegalStateException("A made up Exception"); SessionInitialiser.init(module,session); }catch(Throwable e) { pw = new; out.print("OK, an Exception:"); out.print("
"); } %>

Archive powered by MHonArc 2.6.16.

Top of Page