Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] Trying to get QuickStart working

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] Trying to get QuickStart working

Chronological Thread 
  • From: Curt Blank <>
  • To: Tom Barton <>
  • Cc: Grouper Users <>
  • Subject: Re: [grouper-users] Trying to get QuickStart working
  • Date: Wed, 24 Jan 2007 10:25:02 -0600

Thanks for your reply Tom I do appreciate it, but sources.xml,, pathnames in don't mean anything to me. I am not familiar with java nor tomcat. I am on a steep learning curve here and am just trying to get the Quickstart running to become familiar with this whole thing. I'm used to apache and cgi's and fastcgi's and not this tomcat and java stuff.

I also tried the ant dbgui that was suggested but I don't think that's working either, I get this:

[java] java.sql.SQLException: socket creation error
[java] at org.hsqldb.jdbc.jdbcUtil.sqlException(Unknown Source)
[java] at org.hsqldb.jdbc.jdbcConnection.<init>(Unknown Source)
[java] at org.hsqldb.jdbcDriver.getConnection(Unknown Source)
[java] at org.hsqldb.jdbcDriver.connect(Unknown Source)
[java] at java.sql.DriverManager.getConnection(
[java] at java.sql.DriverManager.getConnection(
[java] at org.hsqldb.util.ConnectionDialog.createConnection(Unknown Source)
[java] at org.hsqldb.util.DatabaseManager.main(Unknown Source)

I do get the HSQL Database Manager window up but that "socket creation error" message is suspect.

Is ant dbgui supposed to start the db too or do I still have to do an ant db in another window?


Tom Barton wrote:

I dropped your war file into my tomcat 5.5 webapps folder, restarted tomcat, substituted sources.xml and for my own (which point to my prototype sources and groups registry, not the quickstart ones) and changed the pathnames in to point to someplace that exists in my file system. Restarted tomcat again, and it works fine.

Not sure what to conclude, but perhaps that helps you to focus your search for the trouble.


Curt Blank wrote:

At first I thought I was on to something when you asked for the war file and I didn't have one, so I made one, but it acts the same. I did the dist and copied everything from the dist/grouper directory to webapps/grouper. Now that I have a war file I see when I start tomcat it creates and populates the webapps/grouper directory itself.

I seem to have made some head way though. I am not running apache anymore during this endeavor.

I think I'm starting to understand some things, I got this:

HTTP Status 404 - /grouper/index.jsp


*type* Status report

*message* _/grouper/index.jsp_

*description* _The requested resource (/grouper/index.jsp) is not available._


Apache Tomcat/5.5.20

When neither the grouper.war file nor the webapps/grouper copied from the dist existed. So that the fact I didn't get that when I did the dist says it was sort of working. So now by the fact I'm getting a blank screen says it's trying to work.

I've included my .war file which I am now using. (gzip'ing it didn't help much so I didn't.)


Curt Blank wrote:

Sorry, meant to answer these questions.

>What versions of Java, Ant and Tomcat are you using?

Java jdk-1.5.0_10-fcs
Ant 1.7.0
Tomcat 5.5.20

>Do you get any error in the Tomcat logs e.g. catlina.out?

No, nothing.


Curt Blank wrote:

Thank you for this! Very informative. Gives me a path to go down, I will give it all a try.


GW Brown, Information Systems and Computing wrote:

--On 22 January 2007 15:09 -0600 Curt Blank

I'm trying to get QuickStart working and this is frustrating. I follow
the instructions provided but I can't get it to work. I am no java or
tomcat expert so that probably has a lot to do with it.

What versions of Java, Ant and Tomcat are you using?

It seems to be doing something I connect to http://localhost:8080/grouper
and it takes me to http://localhost:8080/grouper/ but
then I get a white screen and a Done. I look at the page source and I
have this:

<?xml version="1.0" encoding="iso-8859-1"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"


<html xmlns=""; lang="en-US" xml:lang="en-US">


Do you get any error in the Tomcat logs e.g. catlina.out?

In httpd.conf I put this:

# <IfModule \!mod_jk.c>
LoadModule jk_module modules/
# </IfModule>
# JkWorkersFile "/usr/local/tomcat/conf/jk/"
JkLogFile "/var/log/httpd/mod_jk.log"
JkLogLevel emerg
JkMount /grouper/* ajp13

I had to comment out the IfModule(s) otherwise it wouldn't load. And if I
don't comment out 'JkWorkersFile
"/usr/local/tomcat/conf/jk/"' apache won't start. I
don't know if I need that for QuickStart but the instructions don't
address it either way and if I need a where does it
come from?

In a production environment it is quite likely you would place Apache in front of Tomcat and use mod_jk, however, in order to get the QuickStart to work you don't need to do anything with Apache or mod_jk - you can connect to Tomcat directly.

I'm also still getting this when I try to stop HSQLDB:

[java] Exception in thread "HSQLDB Connection @1b543c88"
java.lang.OutOfMemoryError: Java heap space

This is a direct consequence of using Telnet to shutdown the database. I've never tried doing it this way before.

The QuickStart build file also has a 'dbgui' target which will load a simple database manager ui which lets you query the database, and also shut it down. If you can't do this directly on the machine where the database is installed i.e. no X windows capability, you can connect from a 'desktop' machine by changing the localhost in the URL below:

<java dir="." classname="org.hsqldb.util.DatabaseManager" classpathref="db.class.path" fork="true">
<arg line="-url jdbc:hsqldb:hsql://localhost:9001"/>

This is all extremely frustrating when you follow the instructions and it
doesn't work. Granted being unfamiliar with java and tomcat doesn't help
and I think I have the jk connector installed properly, but the
instructions should take this into account that people not familiar with
all these components will be asked to install this.

I hear your frustration, and the QuickStart is supposed to make it easy to get started specifically to avoid such frustration - and it generally seems to achieve this.

If there is no error in the Tomcat log, I will try and come up with a 'patch' which will produce some diagnostic output. It looks like the error is occurring during initialisation before any Grouper / Subject API calls are made.

In addition you could send me your WAR file + the contents of grouper-qs/grouper/conf and I'll take a look at them to see if I can spot anything.

-Curt Blank

GW Brown, Information Systems and Computing

Archive powered by MHonArc 2.6.16.

Top of Page