Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] Trying to get QuickStart working

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] Trying to get QuickStart working

Chronological Thread 
  • From: Curt Blank <>
  • To: Tom Barton <>
  • Cc: Grouper Users <>
  • Subject: Re: [grouper-users] Trying to get QuickStart working
  • Date: Thu, 25 Jan 2007 17:50:33 -0600

Ok, I'm in the grouper-qs directory, tomcat is not running, db is not running, grouper.script looks good:

# ls -al grouper/dist/run/grouper.script
-rw-r--r-- 1 root root 572105 Nov 3 03:46 grouper/dist/run/grouper.script

Start db:

# ant db
Buildfile: build.xml

[java] [Server@2da679b7]: [Thread[main,5,main]]: checkRunning(false) entered
[java] [Server@2da679b7]: [Thread[main,5,main]]: checkRunning(false) exited
Startup sequence initiated from main() method
[java] [Server@2da679b7]: Loaded properties from [/usr/local/src/grouper/grouper-qs/]
Initiating startup sequence...
Server socket opened successfully in 4 ms.
[java] [Server@2da679b7]: Database [index=0, id=0, db=file:grouper/dist/run/grouper, alias=] opened sucessfully in 558 ms.
Startup sequence completed in 570 ms.
[java] [Server@2da679b7]: 2007-01-25 17:36:04.686 HSQLDB server 1.7.2 is online
[java] [Server@2da679b7]: To close normally, connect and execute SHUTDOWN SQL
[java] [Server@2da679b7]: From command line, use [Ctrl]+[C] to abort abruptly

Looks good. Start dbgui:

Whoa. I'm seeing all kinds of stuff in the left half of the manager display that I've never seen before. Now when I do a SELECT * FROM GROUPER_FIELDS I get all kinds of stuff.

So I connect to 8080/grouper and click on the login link and GrouperSystem login info must have been cached because it took me right to a screen with:

All Groups <>
Search Subjects <>
Saved Groups <>
Saved Subjects <>
Help <>

And lots more. So now it appears to be working. I have no clue why. But it appears I am learning. I still have Gary's initPreLoginSession.jsp in place and you debug stuff displayed.

Now, if it just will continue to work tomorrow when I get back...



Tom Barton wrote:

Curt Blank wrote:

I re-did my build directory from the tar file now I have this:

# ls -al /usr/local/src/grouper/grouper-qs/grouper/dist/run/grouper.script
-rw-r--r-- 1 root root 572105 Nov 3 03:46 /usr/local/src/grouper/grouper-qs/grouper/dist/run/grouper.script

Ok, and no, you don't need to download it again since you've kept an unmodified copy.

But when I start the db then start tomcat then connect to :8080/grouper I still get a blank screen in my browser.

I use the db manager and do a SELECT FROM GROUPER_FIELDS and I still get a Table not found error.

It looks like something blew your database away again. Did you look at the grouper.script file again to verify?

After replacing grouper.script with a fresh copy from the grouper-qs distribution, in the grouper-qs directory run "ant db". What happens? If that appeared to work, in a separate shell window go to the grouper-qs directory and run "ant dbgui". What do you see?


Archive powered by MHonArc 2.6.16.

Top of Page