Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-dev] more trouble with quickstart

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-dev] more trouble with quickstart

Chronological Thread 
  • From: "RL 'Bob' Morgan" <>
  • To: Tom Barton <>
  • Cc:
  • Subject: Re: [grouper-dev] more trouble with quickstart
  • Date: Fri, 7 Oct 2005 20:13:09 -0700 (PDT)

So, I tried modifying to have = DEBUG, stdout, rfile = DEBUG, stdout, rfile

so as to get some debug output (and also set a proper log file), and upon subsequent tomcat restart grouper fails to initialize, apparently with an error of:

2005-10-07 16:59:34,229 ERROR [/grouper]: Error configuring application listener of class edu.internet2.middleware.grouper.ui.GrouperSessionAttributeListener
java.lang.NoClassDefFoundError: javax/servlet/http/HttpSessionAttributeListener

So I went back to the source and modified there, generated the war file again, reinstalled it, started, and voila, I was able to have debug logging to a newly-specified grouper-log file. So that's something. As the qs doc says, always rebuild after changing any conf files.

The perhaps useful logging from that was:

... a bunch of lines of initialization messages ...
2005-10-07 19:45:01,472 DEBUG JDBCSourceAdapter: SQLException occurred: Database does not exists in statement []
java.sql.SQLException: Database does not exists in statement []
at org.hsqldb.jdbc.jdbcUtil.sqlException(Unknown Source)
at org.hsqldb.jdbc.jdbcConnection.<init>(Unknown Source)
at org.hsqldb.jdbcDriver.getConnection(Unknown Source)
at org.hsqldb.jdbcDriver.connect(Unknown Source)
at java.sql.DriverManager.getConnection(
at java.sql.DriverManager.getConnection(

So it looks like it makes a connection to my hsqldb but the database it's looking for does not exist.

I see in sources.xml:

<source adapterClass="edu.internet2.middleware.subject.provider.JDBCSourceAdapter">
<name>UOB QuickStart</name>

So maybe the <id> or the <name> in there is the database name it's looking for for this source? Is one of those the name I should be using in my hsqldb startup command? Which, for the record, was:

java -cp hsqldb.jar org.hsqldb.Server -database.0
/pkg/grouper/grouper-qs/grouper/dist/run/grouper -dbname.0 grouper
-user sa

I tried substituting "-dbname.0 'UOB QuickStart" in the above but it made no difference (ie, still got "Database does not exists" [sic]).

The javax/servlet/http/HttpSessionAttributeListener class is located within servlet.jar in my tomcat 4.1 installation and in servlet-api.jar in my tomcat 5.5 installation, both in the common/lib directory within the tomcat installation. I'm pretty sure I haven't messed with common/lib, so presume that's the way tomcat installs vanilla. As a sanity check, is that jar there in your tomcat install?

Well, this is an odd thing. I can start up tomcat with the grouper webapp just fine (modulo not being able to log in), then I shut it down (using tomcat/bin/, then I start it up again, and the grouper webapp fails to start with the HttpSessionAttributeListener not found error. It seems that only reloading the war file will permit it to start cleanly again. Definitely odd.

- RL "Bob"

Archive powered by MHonArc 2.6.16.

Top of Page