Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-dev] more trouble with quickstart

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-dev] more trouble with quickstart

Chronological Thread 
  • From: Tom Barton <>
  • To: "RL 'Bob' Morgan" <>
  • Cc:
  • Subject: Re: [grouper-dev] more trouble with quickstart
  • Date: Fri, 07 Oct 2005 21:45:49 -0500

RL 'Bob' Morgan wrote:

Yup. You need to run something like

java -cp <location of hsqldb.jar> \
org.hsqldb.Server \
-database.0 <location of grouper database> \
-dbname.0 grouper \
-user sa
(presuming localhost, of course). Note that <location of grouper database> is the pathname of the .script file, exclusive of '.script'. So, if you've got a database in '/opt/registries/grouper-demo.script', put '/opt/registries/grouper-demo' as the -dbname.0 parameter value.

I guess in the qs case this would be


Sure, with an absolute pathname.

which contains 1MB or so of sql. So I did the above command, and indeed hsqldb now appears to be running on port 9001. Unfortunately when trying the web login as GrouperSystem I get the same error page result as before, even after restarting tomcat (ie, "GrouperSystem is not recognised at ...").

So, I tried modifying to have = DEBUG, stdout, rfile = DEBUG, stdout, rfile

so as to get some debug output (and also set a proper log file), and upon subsequent tomcat restart grouper fails to initialize, apparently with an error of:

2005-10-07 16:59:34,229 ERROR [/grouper]: Error configuring application listener of class edu.internet2.middleware.grouper.ui.GrouperSessionAttributeListener
java.lang.NoClassDefFoundError: javax/servlet/http/HttpSessionAttributeListener

The javax/servlet/http/HttpSessionAttributeListener class is located within servlet.jar in my tomcat 4.1 installation and in servlet-api.jar in my tomcat 5.5 installation, both in the common/lib directory within the tomcat installation. I'm pretty sure I haven't messed with common/lib, so presume that's the way tomcat installs vanilla. As a sanity check, is that jar there in your tomcat install?


Archive powered by MHonArc 2.6.16.

Top of Page