Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] Re: gsh -psp -sync and -bulkSync giving different results

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] Re: gsh -psp -sync and -bulkSync giving different results

Chronological Thread 
  • From: David Langenberg <>
  • To: Jeffrey Crawford <>
  • Cc: Gouper Users List <>
  • Subject: Re: [grouper-users] Re: gsh -psp -sync and -bulkSync giving different results
  • Date: Tue, 25 Nov 2014 18:46:06 -0700

I'm sure not only would people like it in the list archive, but it'd also be handy if you would also add a configuration example sub-page linked from the PSP documentation.


On Tue, Nov 25, 2014 at 5:52 PM, Jeffrey Crawford <> wrote:
Okay I've figured this one out. The problem is based on that I'm trying to figure out a way to "make" the psp be configurable to multiple targets that all want different conventions (flat vs bushy, startTLS vs LDAPS, this stem vs that stem, etc.) The way I've found to do that was to find all the items in the psp-resolver.xml and change their name to identify help identify which "set" they belong to, basically I did something like this:

  <!-- SET:
       The names of all groups matching the data connector filter. -->
    <resolver:Dependency ref="AllGroupNamesConnectorSet1" />
    <resolver:Dependency ref="AllGroupNamesConnectorSet2" />

the description in the AllGroupNamesConnectorSet1 said that they return "groupNames", however setting the id to "groupNamesSetX" implies that the attribute it wants to return is also called groupNamesSetX, so I had to add sourceAttributeID="groupNames" to make sure I received the list from the referenced resolver.

Just in case anyone is trying to do something similar I wanted to make sure I circled back and shared in case someone else had the same issue.

If people are interested I'll submit an example of our config once I get it commented.

​Jeffrey C.​

Both pilots and IT professionals require training and currency before charging into clouds!

On Fri, Nov 21, 2014 at 7:49 AM, Jeffrey Crawford <> wrote:
I'm hoping this might be familiar to someone and perhaps can point me to the correct config section that must be wrong I was trying to figure this out for too long now :).

if I run
gsh -psp -sync some:group:name

I get a provisioned group correctly created

if I run
gsh -psp -bulkSync

All of the groups get removed, naturally after it's been running for hours. Is there some section of the config that must be missing the stem config that would trigger when bulkSync runs but not when doing a direct sync?

​ C.

Both pilots and IT professionals require training and currency before charging into clouds!

David Langenberg
Identity & Access Management
The University of Chicago

Archive powered by MHonArc 2.6.16.

Top of Page