Skip to Content.
Sympa Menu

grouper-users - RE: RE: RE: [grouper-users] assignPermissions

Subject: Grouper Users - Open Discussion List

List archive

RE: RE: RE: [grouper-users] assignPermissions

Chronological Thread 
  • From: Chris Hyzer <>
  • To: mohan shamachar <>, "" <>
  • Subject: RE: RE: RE: [grouper-users] assignPermissions
  • Date: Thu, 7 Feb 2013 20:47:00 +0000
  • Accept-language: en-US

I installed 2.1.2 via installer, and tried it, and it worked. So the user
who is using the WS must not have attrUpdate on the attribute definition :)

Try it as a wheel group member to take privileges out of it. Then use the
user which didn't work, and grant the privs on the attribute def and I think
ADMIN on the role, and see if it works.

That error message should be better. Basically it is saying it cant see the
attribute definition you are passing in, and to pass one in that the calling
user can see...

About actions... yes, there is a list of actions associated with the
permission definition (attribute definition). However, each assignment is
the triple of assignee (role or entity_in_context_of_role), resource
(permission name / attribute name), and the action. So when you assign you
need to pass in the action(s) which should be assigned. Ok?


-----Original Message-----

On Behalf Of mohan shamachar
Sent: Thursday, February 07, 2013 2:46 PM

Subject: Re: RE: RE: [grouper-users] assignPermissions

Hi Chris,

I'm getting the same error: WsInvalidQueryException: You need to pass in an
attributeDefName lookup.

I tried removing the empty uuid tag. I also tried including and excluding
actions. Not sure why we have to send a list of actions if the permission
already has a few actions defined.

It appears that I need to upgrade the grouper to 2.1.3. I'm currently running
2.1.2. am I correct?

Also, is there a way to get a list of all permissions stored in a folder
(stem) ?.

thank you,


Archive powered by MHonArc 2.6.16.

Top of Page