Skip to Content.
Sympa Menu

grouper-users - Re: Re: [grouper-users] Ldap import data from grouper fail

Subject: Grouper Users - Open Discussion List

List archive

Re: Re: [grouper-users] Ldap import data from grouper fail

Chronological Thread 
  • From: "Allen Chen" <>
  • To: "Tom Barton" <>
  • Cc: "" <>
  • Subject: Re: Re: [grouper-users] Ldap import data from grouper fail
  • Date: Wed, 8 Aug 2007 09:08:40 +0800


Allen Chen

发件人: Tom Barton
发送时间: 2007-08-07 22:00:22
收件人: chqh
主题: Re: [grouper-users] Ldap import data from grouper fail
>chqh wrote:
>> But another problem come again.
>> There are 79 groups in the grouper registry. And when the ldappc program 
>> ran, the first 58 groups data provisioning worked well. But the rest 21 
>> groups' provision failed.
>> Every time it happens.
>> Then I check the grouper_error.log and the same exceptions happened 
>> again and again (maybe hundreds).
>> Here is part of grouper_error.log :
>> 2007-08-07 10:08:17,296: Ldap NamingException:
>> javax.naming.CommunicationException:[Root exception is 
>> Address already in use: connect]
>What's the range of how many members each of your groups has? Any deep 
>subgroup structure or extensive use of composites? Is there anything 
>distinctive about group 59?
One group( Teacher group) has more than 4300 members, and the each groups of the rest has about 300 member. The structure is simple, just something like that
a group contains simple person members and no composites. Group 59th's structure is the same as other groups.
Now the ldappc program just provisions about 900 members into the Teacher group where has 4300 members. And some groups' members cannot
be added even they have less than 100 members, which happens both before and after the Teacher group is processd. It's really weird!
I try to raise the maxElementsInMemory number in the ehcache.xml, which actually didn't help.
>Is there a limited pool of port numbers higher than 1024 available on 
>the machine running ldappc? What OS is the ldappc host running?
The ldappc host is running on windows. The port numbers higher than 1024 is available on the pc I worked on.
In fact, what makes me confused is the following error:
Ldap NamingException:
>> javax.naming.CommunicationException:[Root exception is 
>> Address already in use: connect]
where is the address of ldap server.Is there something wrong with the server?

Archive powered by MHonArc 2.6.16.

Top of Page