Skip to Content.
Sympa Menu

grouper-dev - Re: [grouper-dev] DB problem - some broken groups - help appreciated.

Subject: Grouper Developers Forum

List archive

Re: [grouper-dev] DB problem - some broken groups - help appreciated.

Chronological Thread 
  • From: Shilen Patel <>
  • To: "Gettes, Michael" <>
  • Cc: "" <>
  • Subject: Re: [grouper-dev] DB problem - some broken groups - help appreciated.
  • Date: Fri, 31 May 2019 20:21:23 +0000

I wonder why it’s finding so many issues. If you run it again, does it find
more? You can run it via the daemon which would keep running it until it
doesn’t find anymore (or quit after 4 attempts). Before going into the db
and deleting rows out of grouper_group_set, it would be good to know if this
fixes it or not.


- Shilen

On 5/31/19, 4:03 PM, "Gettes, Michael" <> wrote:

Shilen - findBadMemberships found 3 bad or missing this time around.

Re-ran the loader job again and i still get the 14-ish errored groups as


> On May 31, 2019, at 2:49 PM, Gettes, Michael <> wrote:
> at 2:56am this morning findBadMemberships reported:
> Found 8 bad or missing memberships. Fixing and will try again. Found 1
bad or missing memberships. Fixing and will try again. Found 42 bad or
missing memberships. Fixing and will try again. Found 0 bad or missing
> running it again.
> /mrg
>> On May 31, 2019, at 2:47 PM, Gettes, Michael <> wrote:
>> my last response was before I read this. running findBadMemberships
now which runs every nite at 2am.
>> Carey - i hope my previous response sorta answers your questions.
>> /mrg
>>> On May 31, 2019, at 2:43 PM, Shilen Patel <> wrote:
>>> Have you tried to run findBadMemberships()? Depending on what the
group set issue is, that may or may not help.
>>> - Shilen
>>> On 5/31/19, 1:43 PM, " on behalf of
Gettes, Michael" < on behalf of
> wrote:
>>> I’m trying to decipher the error presented…
>>> Caused by: java.sql.BatchUpdateException: Cannot delete or update a
parent row: a foreign key constraint fails (`grouper`.`grouper_group_set`,
CONSTRAINT `fk_group_set_member_group_id` FOREIGN KEY (`member_group_id`)
REFERENCES `grouper_groups` (`id`))
>>> I read this to imply there is a value in
grouper_group_set.member_group_id that is not in
>>> To prove, I ran a right outer join to find what’s in group_set that
is not in groups
>>> select * from grouper.grouper_group_set gs
>>> right join grouper.grouper_groups g
>>> on gs.member_group_id =
>>> where gs.member_group_id = null
>>> and got 0 records returned.
>>> i am not sure where the problem is - any guidance?
>>>> On May 31, 2019, at 11:16 AM, Gettes, Michael <> wrote:
>>>> Hi all,
>>>> I have a condition of about a dozen groups which cannot be modified
or deleted and the log snippet attached shows the error log for one of these
groups. First, I’d like to know how I fix these groups. Second, the
condition of how this occurred I am still trying to prove but it seems to be
related to whether or not memory is configured with ms=mx. I haven’t been
able to recreate what caused the condition in the log snippet but the log
snippet with ms=mx devolves into Garbarge collection failures and the loader
becoming unusable over time. With ms<mx (8g<9g) the errors i see in the log
snippet do not cause the loader to become unusable over time. Anyway, I’d
really appreciate help fixing the bad groups based on the log.
>>>> I decided not to post this to the grouper-users list because I don’t
want people thinking grouper is unstable and this could happen to them. As
you guys know, i have been doing some extreme things with grouper to see
what’s possible and find issues and i think these “broken groups” are related
to that work and the various memory problems I was having.
>>>> Thank you!
>>>> /mrg
>>>> <20190531-grouper-error.log>

Archive powered by MHonArc 2.6.19.

Top of Page