Skip to Content.
Sympa Menu

grouper-dev - RE: [grouper-dev] upgrade to 1.5 experience

Subject: Grouper Developers Forum

List archive

RE: [grouper-dev] upgrade to 1.5 experience

Chronological Thread 
  • From: Chris Hyzer <>
  • To: Chris Hyzer <>, Jim Fox <>
  • Cc: Jim Fox <>, "" <>
  • Subject: RE: [grouper-dev] upgrade to 1.5 experience
  • Date: Wed, 18 Nov 2009 14:04:53 -0500
  • Accept-language: en-US
  • Acceptlanguage: en-US

Im sorry, I was on an old version of grouper.  I cant reproduce on the latest version.  The key to postgres is that at the top it should drop all views and foreign keys.  If you don’t see that at the top of the script, then I wonder if you have the default schema being used.  You could try setting this in to something else


ddlutils.schema = public


Jim, if you don’t see the drop foreign key statements at the top, let me know and I can put some debug info in there.  If we want to skip this issue, we could say “If using postgres, then make sure at the top of the script it drops foreign keys, if not, then manually drop your grouper foreign keys then run the script”.


Note, ddlutils will create backup tables for postgres when it doesn’t have to, I think it is fixed in the next version of ddlutils which isn’t out yet, but it is harmless.





From: Chris Hyzer
Sent: Wednesday, November 18, 2009 1:08 AM
To: 'Jim Fox'
Cc: Jim Fox;
Subject: RE: [grouper-dev] upgrade to 1.5 experience


I tried this and was able to reproduce… let me look into this on wed and get back to you…


1.       Drop all objects from postgres (I run a 1.5.0 gsh –registry –drop, and copy and paste the first bunch of drop lines only)

2.       Then in 1.4 (latest on branch), run this:

C:\temp\grouper_v1_4_20091110\bin>gsh -registry –runscript

3.       Run a check:

C:\temp\grouper_v1_4_20091110\bin>gsh -registry -check

Are you sure you want to schemaexport all tables (dropThenCreate=F,writeAndRunScript=F) in db user '

grouper', db url 'jdbc:postgresql:grouper'? (y|n):



NOTE: database table/object structure (ddl) is up to date




4.       Import users and quickstart


C:\temp\grouper_v1_4_20091110\bin>gsh -registry -runsqlfile ..\subjects.sql

Are you sure you want to run the sql file in db user 'grouper', db url 'jdbc:postgresql:grouper'? (y|n): y


Script was executed successfully

C:\temp\grouper_v1_4_20091110\bin>gsh -xmlimport GrouperSystem ..\quickstart.xml

Are you sure you want to import data from xml in db user 'grouper', db url 'jdbc:postgresql:grouper'? (y|n): y


5.       Verify registry is there


Type help() for instructions

gsh 0% getGroups("%a%");

gsh 1%


6.       Upgrade to 1.5
F:\temp\grouper_HEADtest\bin>gsh -registry –check

ARG!!!! Backs up tables but doesn’t drop foreign keys…  need to investigate





From: Jim Fox [mailto:]
Sent: Tuesday, November 17, 2009 11:06 PM
To: Chris Hyzer
Cc: Jim Fox;
Subject: Re: [grouper-dev] upgrade to 1.5 experience



   so it appears some tables are dropped.

You had the latest grouper code with "ant dist", right?  Can you send me the sql script mentioned above?  I hope you had a backup of your tables


This was my development setup.  So no harm done.  I think I have a copy of the script.  I'll send it tomorrow.



   Postgres automatically creates constraints on many key generations.

Hmmm, I didn't get that when I upgraded my quickstart I believe...


I might give it a try from the puny quickstart DB.





At this point the 1.5 database seems OK.  However,


If I create a root session and do a query for groups by member

(GroupMemberFilter) I get back the list of groups immediately.


If I create a user session and do a query for groups by member

I get back the list of groups in twenty seconds!


Is this expected?  Or am I missing an index somewhere?


I don't know how to query the information_schema for indexes (does anyone?) but when you browse the tables (e.g. in pgadmin) do you see 14 indexes on grouper_group_set, 11 indexes on grouper_groups, and 20 indexes on grouper_memberships?


I have one more than that in each case.  I'm going to give a clean DB a try, and see what comes of that.




Archive powered by MHonArc 2.6.16.

Top of Page