Skip to Content.
Sympa Menu

grouper-users - [grouper-users] docker environment issue?

Subject: Grouper Users - Open Discussion List

List archive

[grouper-users] docker environment issue?

Chronological Thread 
  • From: "T-Heetderks" <>
  • To:
  • Subject: [grouper-users] docker environment issue?
  • Date: Wed, 15 Jul 2020 07:27:29 +0000

My workstation is a Macbook Pro, and I have a server on our university
infrastructure setup for grouper. I am still in the process of initial setup.
I can run the following quickstart command on my Macbook and it works fine.
But when I run it on my server, it goes south somewhere. It appears to be
listening to port 443 but it never responds.

sudo docker run --detach --name grouper-qs0 \
--publish 443:443 -e GROUPER_MORPHSTRING_ENCRYPT_KEY=abcdefg12345dontUseThis
-e GROUPERSYSTEM_QUICKSTART_PASS=testing123 i2incommon/grouper:2.5.29

I have been trying to compare logs to look for a discrepancy, and I did find
this-- when I run the docker logs command on the failing instance, it gives me
these errors (spit out to stderr):

chown: cannot access '/opt/grouper/grouperWebapp/WEB-INF/lib/slf4j-jdk14-
1.7.21.jar': No such file or directory
chown: cannot access '/opt/tomee/lib/hsqldb-2.3.2.jar': No such file or

Any ideas why my server doesn't seem to want to run this container?? I am
running docker version 19.03.12. It acts like it starts and runs OK... but its
just not running Docker.

Thanks for the help.
- Thomas

  • [grouper-users] docker environment issue?, T-Heetderks, 07/15/2020

Archive powered by MHonArc 2.6.19.

Top of Page