Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] grouper 2.5 gsh/database

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] grouper 2.5 gsh/database

Chronological Thread 
  • From: Thomas Heetderks <>
  • To: "Hyzer, Chris" <>, "" <>, T-Heetderks <>
  • Subject: Re: [grouper-users] grouper 2.5 gsh/database
  • Date: Tue, 2 Jun 2020 06:49:01 -0600

Thanks so much Chris -

moving from .28 to .29 made a big difference (eliminated the error I was getting)...
The "" worked beautifully too.

One problem I am having... in my:

sudo docker service create --detach --publish 8443:443 --publish 3306:3306 --name grouper-ws \

The network port stuff doesn't seem to be working anymore (was working on 2.4)...
I had to switch to "--network host" to get the database to work.

- Thomas

On 5/30/20 9:13 AM, Hyzer, Chris wrote:
also if you set this in it will generate the database without a GSH call... = 2.5.*

But you should also use latest
From: on behalf of T-Heetderks
Sent: Saturday, May 30, 2020 11:06 AM
Subject: [grouper-users] grouper 2.5 gsh/database
I am wrestling with changes in 2.5

For example-- generating the initial database:

(in 2.4 this worked)
sudo docker container run -it --rm --network host  \
   --mount type=bind,src="$(pwd)/,dst=/run/secrets/  \
   tier/grouper gsh -registry -check -runscript -noprompt

Seems like 2.5 also needs:
sudo -u tomcat

SO-- my first question is: is this right, or how do I generate the initial
database in 2.5 ??

Which leads to my second question...

Every time I try to launch gsh (as tomcat-- shelled into my service or as a
distinct docker container), I get this error:
./ line 205: java: command not found

WHY-- what is causing this error ??

Thanks again and in advance for the help!!
- Thomas

Archive powered by MHonArc 2.6.19.

Top of Page