Skip to Content.
Sympa Menu

grouper-users - RE: [grouper-users] grouper 2.5 gsh/database

Subject: Grouper Users - Open Discussion List

List archive

RE: [grouper-users] grouper 2.5 gsh/database

Chronological Thread 
  • From: "Hyzer, Chris" <>
  • To: Thomas Heetderks <>, "" <>, T-Heetderks <>
  • Subject: RE: [grouper-users] grouper 2.5 gsh/database
  • Date: Sat, 20 Jun 2020 17:59:47 +0000
  • Arc-authentication-results: i=1; 1; spf=pass; dmarc=pass action=none; dkim=pass; arc=none
  • Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed;; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=aCAnz5+2eCDkWGhnG63RYnqm1AeTu1WlW3v81egReac=; b=HXBJPAUf1ohQ+hPL5EfmXU+0zuhBBIUHuTRGCwTye9sincEQjzTg+usXjI8WFgEZdBirK0XlC5Fv6CRo2kOoauKKvLfND1uOEd5Zk05vZ0efnvWKXV+hR4sqovPdni8EcUr04qWByBDHw5TzTFdQDTza5oQCZtzNLV9rd7QUWX2AHHIFlthFa8ue3FSnVT7jyiM7mvAQWHx94pZme9Qi2dWqQPWdI1b3SEpR1ClJIgPYZiboaqf5uIqF8g9H+QSHgh4KxgSUNzOj2sdZjSp/gLlV+QwQyWvx+eq9d5QLQaVHtxvfMqXcjt2y08FqEnvvvNddgZg3rtTXLNAU/IsybQ==
  • Arc-seal: i=1; a=rsa-sha256; s=arcselector9901;; cv=none; b=NNyQzjj94CeO6lnkiKY86b723tFAvjC8QKowwS4D51sLMCSUh6fkFtq+0/aaxAA8tDIwH8KS6GG36RIqC77RD8v/PKvkZh/nM5/Gr3mvawpN+DUuM/ys/WvmWxtHFHCISUfnALXvv2KVq+1sAHYRB3FeCZmCIgLAi5KBLmYIFLW9HYTEpdxF3L7S5bexUXkZ7GnyOcwojzOdnC3uWEc6cbM/s7VUtKwCu7rm90wHyPf9KmpxUghCrNVfR9fzI69TYq8FVbr3/euj4d80vfXtCPTct6lxrDmJVbkL5qkcWhyWMObzWDY02RlywO23w3mpKC5M/U7gRBEctgjGKaf+8Q==

Is your database running in a different container?  You should be able to access that by IP address right?  if you have “–network host” set and you are happy with it, that’s fine.  But nothing in 2.5 should preclude normal docker networking


From: On Behalf Of Thomas Heetderks
Sent: Tuesday, June 02, 2020 8:49 AM
To: Hyzer, Chris <>; ; T-Heetderks <>
Subject: Re: [grouper-users] grouper 2.5 gsh/database


Thanks so much Chris -

moving from .28 to .29 made a big difference (eliminated the error I was getting)...
The "" worked beautifully too.

One problem I am having... in my:

sudo docker service create --detach --publish 8443:443 --publish 3306:3306 --name grouper-ws \

The network port stuff doesn't seem to be working anymore (was working on 2.4)...
I had to switch to "--network host" to get the database to work.

- Thomas

On 5/30/20 9:13 AM, Hyzer, Chris wrote:

also if you set this in it will generate the database without a GSH call... = 2.5.*


But you should also use latest

From: on behalf of T-Heetderks
Sent: Saturday, May 30, 2020 11:06 AM
Subject: [grouper-users] grouper 2.5 gsh/database


I am wrestling with changes in 2.5

For example-- generating the initial database:

(in 2.4 this worked)
sudo docker container run -it --rm --network host  \
   --mount type=bind,src="$(pwd)/,dst=/run/secrets/  \
   tier/grouper gsh -registry -check -runscript -noprompt

Seems like 2.5 also needs:
sudo -u tomcat

SO-- my first question is: is this right, or how do I generate the initial
database in 2.5 ??

Which leads to my second question...

Every time I try to launch gsh (as tomcat-- shelled into my service or as a
distinct docker container), I get this error:
./ line 205: java: command not found

WHY-- what is causing this error ??

Thanks again and in advance for the help!!
- Thomas


Archive powered by MHonArc 2.6.19.

Top of Page