Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] Red Hat Linux installation conundrum for oracle.jdbc.driver.OracleDriver

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] Red Hat Linux installation conundrum for oracle.jdbc.driver.OracleDriver

Chronological Thread 
  • From: Linda Toth <>
  • To: Andrew Morgan <>
  • Cc:
  • Subject: Re: [grouper-users] Red Hat Linux installation conundrum for oracle.jdbc.driver.OracleDriver
  • Date: Thu, 13 Aug 2015 14:42:51 -0800

Scott Koranda's suggestion did the trick.  I placed the driver in ~/grouper.apiBinary-2.2.1/lib/custom and zipped right through.


Linda Toth
University of Alaska - Office of Information Technology (OIT) - Identity and Access Management
910 Yukon Drive, Suite 103
Fairbanks, Alaska 99775
Tel: 907-450-8320
Fax: 907-450-8381

On Thu, Aug 13, 2015 at 2:41 PM, Andrew Morgan <> wrote:
On Thu, 13 Aug 2015, Linda Toth wrote:

Good afternoon,

I tried out grouper installation first by installing in on my desktop (Mac
OS/X) and using the hsqldb.  Although it was 100% smooth, I was able to
reason out what was needed to completed the installation and had grouper up
and running within a day.

The RHEL installation is not going well.  In production, we will be using
Oracle rather than the bundled database.

By reading the documentation and reviewing the tutorial, it is implied that
all drivers needed for an installation are included in the installation
package.  However, once I have entered the hibernate.connection.url,
hibernate.connection.username, and hibernate.connection.password, the
program throws the following exception trace (despite adding the
ojdbc14.jar driver to a library and including it in the classpath.  The
lines indicating issues in finding ojdbc14.jar are in red):

Checking database with query: select 1 from dual

Error: could not connect to the database:

java.lang.RuntimeException: Error with query: select 1 from dual
Caused by: java.lang.RuntimeException: Error connecting to: null
Caused by: java.lang.RuntimeException: Problem loading class:
Caused by: java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

I ran into the same problem with the installer.  My installation notes say:

Database user: grouper
Database password:
(can't find oracle.jdbc.driver.OracleDriver, continuing)
install patch grouper_v2_2_1_api_patch_0: t
install patch grouper_v2_2_1_api_patch_1: t
install patch grouper_v2_2_1_api_patch_2: t
install patch grouper_v2_2_1_api_patch_3: t
init the database: (press CTRL-C here to break out of the installer)

Then I proceeded with configuration by hand and initialized the database later:

cd /private/grouper/api/bin
./gsh -registry -check
    schemaexport all tables: y
./gsh -registry -runsqlfile /private/grouper/api/ddlScripts/<filename>.sql
    run the sql file: y

I'm not sure why the installer had that error, but I just skipped it.


Archive powered by MHonArc 2.6.16.

Top of Page