Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] grouper DB 2.2.1 upgrade from 2.1.4 issues

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] grouper DB 2.2.1 upgrade from 2.1.4 issues

Chronological Thread 
  • From: Shilen Patel <>
  • To: Rahul Doshi <>, "" <>
  • Subject: Re: [grouper-users] grouper DB 2.2.1 upgrade from 2.1.4 issues
  • Date: Fri, 5 Dec 2014 16:11:35 +0000
  • Accept-language: en-US

Regarding the first issue, it seems like something may have been making changes in that grouper instance while you were trying to upgrade?  Since you say you made sure the temp table was empty, but then you later had to delete from the table to continue.


— Shilen

From: Rahul Doshi <>
Date: Friday, December 5, 2014 at 9:58 AM
To: "" <>
Subject: [grouper-users] grouper DB 2.2.1 upgrade from 2.1.4 issues


I did another test upgrade for our current production grouper database.  I was able to perform the upgrade but the process wasn’t entirely smooth.  Here are some of the issues that I faced which I might indicate a bug in the upgrade process or something that I am doing wrong.

  1. When I tried to generate the upgrade script using ./gsh –registry –check  it asked me to run loaderRunOneJob("CHANGE_LOG_changeLogTempToChangeLog”) from the current grouper.  I was surprised by the message because I did do that step before I ran ./gsh –registry –check but anyways I went ahead and ran  loaderRunOneJob("CHANGE_LOG_changeLogTempToChangeLog”)  and made sure nothing is in the change_log_entry_temp table. Second time I tried to generate upgrade script again I got the same message.  I kept doing this couple of times as you can see from the changelogentries below before I decided to delete changelogtemp entry right before I enter response yes when ./gsh –registry –check asks "Are you sure you want to schemaexport all tables (dropThenCreate=F,writeAndRunScript=F) in db user ‘xxxx', db url 'jdbc:mysql://xxxxl/xxx'? (y|n)” and that worked.
change_log_type_id context_id created_on sequence_number string01 string02 string03 string04 string05 string06 string07 string08 string09 string10 string11 string12
792e47bdfb6748e18bc5a39aea2cd869 65cdcaf595134415972192894a5a9041 1.41773E+15 8461680   b2919af998f04ab387eaf1fff1d0abe4 groupAttrReaders access
792e47bdfb6748e18bc5a39aea2cd869 ee04c1cb97e44405b05e2dec2f716be4 1.41773E+15 8461681   d0376921bfaf42a7b06ead304f2c5b2e groupAttrReaders access
792e47bdfb6748e18bc5a39aea2cd869 4e5607cb32864c13a6b7defcf8e3b3ab 1.41773E+15 8461682   064401bf77d44f3fb0a444e7f566ecdb groupAttrReaders access
792e47bdfb6748e18bc5a39aea2cd869 e871fece49884f2d971b67825850efa1 1.41773E+15 8461683   17e939ee727f4121a614d6cb7d757fe4 groupAttrReaders access

2.  Second issue that I faced was upgrade script aborted half way with the error"2014-12-04 14:18:42,291: [main] ERROR GrouperAntProject.log(73) -  - Failed to execute:   CREATE VIEW grouper_rpt_group_field_v (GROUP_NAME, GROUP_DISPLAYNAME, FIELD_TYPE, FIELD_NAME, MEMBER_COUNT) AS select as group_name, gg.display_name as group_displayName, gf.type as field_type,”.  This is simply because script doesn’t generate DROP VIEW statement for grouper_rpt_group_field_v and when it tries to create that view it fails.  To workaround the problem when I ran the upgrade script I manually deleted that view and everything worked


Archive powered by MHonArc 2.6.16.

Top of Page