Skip to Content.
Sympa Menu

grouper-users - RE: [grouper-users] I dislike Active Directory

Subject: Grouper Users - Open Discussion List

List archive

RE: [grouper-users] I dislike Active Directory

Chronological Thread 
  • From: Gagné Sébastien <>
  • To: "Bryan E. Wooten" <>, <>
  • Subject: RE: [grouper-users] I dislike Active Directory
  • Date: Tue, 30 Apr 2013 08:45:11 -0400
  • Authentication-results:; dkim=neutral (message not signed) header.i=none

Unfortunately I haven’t tried with large queries and we aren’t currently using it, but from what I see from my tests I didn’t even uncomment most of the properties, so eventually I might run in the same problem.


Looking at vt-ldap’s properties (, maybe you should try setting the “pagedResultsSize” properties : ldap.personLdap.pagedResultsSize = 800


I’m not 100% sure what’s the difference between this one and “batchSize”, but my guess would be that “pagedResultSize” is used when searching in ldap while “batchSize” is used when accessing the data by calling vt-ldap.


De : [mailto:] De la part de Bryan E. Wooten
Envoyé : 29 avril 2013 16:47
À :
Objet : [grouper-users] I dislike Active Directory


Here I go again. I am trying to create a groups from attributes. (we have an attribute called uuemployee and I want to create a group of uuCurrentEmployee).


This group definition works fine against LDAP but when I point at AD I only get 859 members, but the result should be over 30k.


I have tried changing this:


ldap.personLdap.batchSize = 800


ldap.personLdap.countLimit = 600000


ldap.personLdap.timeLimit = 600000


But it has no effect on the results.


Can someone send me their sanitized and that actually work with large AD datasets?


When I use same AD account in my Softterra LDAP browser I can read everything, so I don’t think it is an AD configuration issue.





Archive powered by MHonArc 2.6.16.

Top of Page