Skip to Content.
Sympa Menu

grouper-users - RE: [grouper-users] Lite UI Authentication

Subject: Grouper Users - Open Discussion List

List archive

RE: [grouper-users] Lite UI Authentication

Chronological Thread 
  • From: Richard James <>
  • To: "'GW Brown, Information Systems and Computing'" <>, "" <>
  • Subject: RE: [grouper-users] Lite UI Authentication
  • Date: Thu, 4 Feb 2010 14:32:28 +0000
  • Accept-language: en-US, en-GB
  • Acceptlanguage: en-US, en-GB


Thanks for pointing that out Gary, that has solved the problem with the Admin
UI, we can now successfully authenticate straight through to the UI as

For the Lite UI, I have had a look at the grouper error log for any entries
when trying to access the Lite UI, the only error we seem to catch from
groupers perspective is;

2010-02-04 14:17:51,471: [TP-Processor6] ERROR
PopulateErrorAction.execute(70) - Caught '403' for

I have set the logging to catch everything at the moment. We have been
looking around the code ourselves to try and work out why its behaving like
it is, but so far a bit of a loss.



>-----Original Message-----
>From: GW Brown, Information Systems and Computing
>Sent: 03 February 2010 16:18
>To: Richard James;
>Subject: Re: [grouper-users] Lite UI Authentication
>Hi Richard,
>For the Admin UI follow the instructions for the yale-cas contribution
>contrib/yale-cas-auth/README.html - starting with 'In order to
>The link there is now out-of-date - try
>Unfortunately the stack trace indicates there was an error in our error
>processing so I can't tell what the original error was. If that trace
>from a tomcat log is there anything in grouper_error.log? There is a
>LOG.error("Caught '" + code + "' for " ... statement so I would hope
>something made it to a log.
>--On 03 February 2010 10:43 -0500
> wrote:
>> Hi All,
>> First of all just want to say great work on the latest version of
>> Grouper, the auditing features and the new Lite UI will be of great
>> benefit to us. Also, thanks for the release for the bug fixes as this
>> solved an issue we were having when attempting to do an import via the
>> GSH xml-import tool :)
>> We are having one problem regards to the Lite UI, we have successfully
>> deployed both the admin UI and the lite UI, and successfully managed
>> log in to both interfaces using Tomcat authentication. Though when we
>> turn Tomcat authentication off, and protect the UI's with Shib, we are
>> coming across some problems.
>> If logging into the admin UI via http://<server-name>/grouper, we are
>> directed to our Shib login page, once credentials are entered we are
>> directed through to the grouper home page and are presented with the
>> stem.
>> Though if we attempt to login into the admin UI via
>> https://<server-name>/grouper/ or the Lite UI via
>> https://<server-
>> mpleMembershipUpdate.index we encounter "HTTP Status 403 - Access to
>> requested resource has been denied." I presume this is because these
>> calling the java login functions unlike the http://<server-
>> URL which is redirected straight through to the page. Looking
>> into the logs there is the following entry;
>> 28-Jan-2010 11:27:39 org.apache.catalina.core.ApplicationDispatcher
>> SEVERE: Servlet.service() for servlet action threw exception
>> java.lang.NullPointerException
>> at
>> ourceBundle( at
>> at
>> at
>> 26) at
>> at
>> at javax.servlet.http.HttpServlet.service(
>> javax.servlet.http.HttpServlet.service( at
>> at
>> at
>> at
>> at
>> at
>> at
>> 416) at
>> 343) at
>> 144) at
>> 102) at
>> ava:109) at
>> 3) at
>> org.apache.jk.server.JkCoyoteHandler.invoke(
>> at org.apache.jk.common.HandlerRequest.invoke(
>> at org.apache.jk.common.ChannelSocket.invoke(
>> at
>> 98) at
>> ava:891) at
>> java:690) at
>> Not sure why this is, I guess it maybe something to do with the way
>> LoginCheckFilter works with Grouper. I have looked around the code to
>> and work this out but so far with no success, the only assumption I
>> make is that it is failing to retrieve HTTP session details when
>> the retrieveHttpServletRequest method. Does anyone else protect
>> via Shib and has come across this problem? Or anyone have any ideas on
>> how we can get round this?
>> Many Thanks
>> Richard James
>> ISS Middleware Team
>> Newcastle University
>GW Brown, Information Systems and Computing

Archive powered by MHonArc 2.6.16.

Top of Page