Skip to Content.
Sympa Menu

comanage-users - Re: [comanage-users] [External]Re: LDAP Source debugging

Subject: COmanage Users List

List archive

Re: [comanage-users] [External]Re: LDAP Source debugging

Chronological Thread 
  • From: Benn Oshrin <>
  • To: "" <>
  • Subject: Re: [comanage-users] [External]Re: LDAP Source debugging
  • Date: Tue, 15 Mar 2022 16:49:03 -0400

"OrgIdentity saveAssociated" probably means there is not enough information to save the record retrieved from LDAP to the database, or one (or more) of the fields isn't validating correctly. (Also possible that there is a bug in transforming the data, causing the same error.)

Unfortunately, we don't have great tooling to identify the error at the moment, so it's going to take a bit of trial and error.

Off list, if you can send Scott and myself the following it would help us pin this down:

- LdapSource "Key Attribute" and "Search Filter" configuration.
- A sample LDAP record you are trying to read, including the "Supported Attributes" defined in the wiki[1].




On 3/15/22 4:34 PM, Richard Frovarp (via comanage-users Mailing List) wrote:
I'm seeing the same thing taking the same troubleshooting steps. I'm on 4.0.2 with PHP 7.4

On 3/15/22 13:07, "Daniels, John" (via comanage-users Mailing List) wrote:
Ah okay, thanks for the clarification.
I went through the steps again and I still get the same 'Database save failed: OrgIdentity saveAssociated' error when trying to import a single record.


On 3/15/22, 1:12 PM, "Scott Koranda" <> wrote:

     [You don't often get email from . Learn why this is important at]
     > Loading schema from file /srv/comanage/comanage-registry-4.0.1/local//Plugin/LdapSource/Config/Schema/schema.xml...
     The line above means that the plugin and its schema were found and
     > Possibly failed to update database schema
     That line is a "red herring". The schema management tool used in
     COmanage Registry 4.x (Adodb, which will be replaced in the 5.x series)
     will output that line even if the schema was processed correctly. You
     can safely ignore it.
     Please continue by deleting the cache (again) and then trying to import
     a single source record and let's see if you get the error again.
     ** This email originated from an EXTERNAL sender to CHOP. Proceed with caution when replying, opening attachments, or clicking links. Do not disclose your CHOP credentials, employee information, or protected health information to a potential hacker**.

Archive powered by MHonArc 2.6.24.

Top of Page