Skip to Content.
Sympa Menu

comanage-users - Re: [comanage-users] LDAP Source debugging

Subject: COmanage Users List

List archive

Re: [comanage-users] LDAP Source debugging

Chronological Thread 
  • From: Scott Koranda <>
  • To: "Daniels, John" <>
  • Cc: "" <>
  • Subject: Re: [comanage-users] LDAP Source debugging
  • Date: Tue, 15 Mar 2022 11:02:21 -0500
  • Arc-authentication-results: i=1; 1; spf=pass; dmarc=pass action=none; dkim=pass; arc=none
  • Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed;; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=bbhimLsipUJSc3Z6pg38gdB+yep35ufAqaefqfUCabM=; b=G3LppwTkbtpa1h4C7A2t/S7J8QSjFeaxieRqJFvyY5YmpIw9M3E8xLLD6plWjvZES9s/VwE6WpBnZ0YWsqbStYIWxbHj4g1jjlGMwyrjUxUmayyPZ/8EY60vNAtFRK7eC4CIVQpP8DjBFoMQSeKCOl6KvC0txbQIjBCnOwnadMuST6BfBg2w5KuwTEuwcN90d/JVILbAXAOfedU4TGcxqL6dCKinQJvcI3HlOKwAw126jVpGXrqCczWDJYAtHzRgH2TlLKT+9Fo+ccZR1pZC8VjCC5rkxCYN2D5e87zXbE3UdzfsaIdnNZsDtBxkT6cyU5kojXqqZUKo0aTQWQ5jXw==
  • Arc-seal: i=1; a=rsa-sha256; s=arcselector9901;; cv=none; b=B3kLEmjLzpCzW4qbY1jeTIu7BD/nzLDa+v2scn/WqqUkFI10JXid6idOijeITLCIM17ulPfLZNhQKEkLaqIZ1T4+wYzLya3feDPJBNO8Bwd8UqJkhLWiTjzq+lVgMY0bf6mMfqrfOBoTQIfX2NpeNM57kL9FQjJDlJl2xfGvcaLUZhOq3hsFqL5fJtqvnKWzRMbDHNf5dPFlkbxx5RO6pqSXfFiUAzS4PGL6mJti4Uj1yLRns2mSwimZ5ZDVoZZQwSR13kdlgFh55rDiE0ikIfDNUd4nWZSkn32Sox+HZRneCnekhV4k1h7gntfyxaaUz6zIc06mZ8o2jQpEQ1GBbQ==

Hi John,

Here is how I would start:

- Clear the cache that CakePHP saves for models. I like to do it by
changing to the tmp directory you set up during install [1]
and doing

find ./cache -type f -delete

- Next make sure the database schema is up to date after you "installed"
the LdapSource plugin by doing

cd .../app
./Console/cake database

I usually run that as root because I am in a hurry. If you want to run
it as the web server user (httpd or www-data) you will probably need
to use su or sudo.

- Clear the cache again, especially if you ran the previous command as

cd .../tmp/
find ./cache -type f -delete

- Now try again for a single source record. Do you get the same error?

If so the "saveAssociated" is caused when some model related to the
OrgIdentity cannot be saved. It is often an Identifier that cannot be
saved, probably because it already exists and is attached to an object.
Is that the case?

I know these are simple steps. Can you try them and if you are still
having the issue let us know and we can dig further.



> How do I go about debugging the LDAP Source Plugin?
> I have it setup and I can view inventory on the org identity source. The
> records I view from there look right. (Only thing off might be that ‘source
> record’ is empty, unclear if that’s normal from this view..)
> When I go to ‘add new org identity from source’ and I get a UI error of
> “Database save failed: OrgIdentity saveAssociated”
> I have tried increasing to debug in core.php and viewing the php logs in
> the tmpdir and in my php-fpm logs. Nothing shows up. Beyond that, I’ve
> injected some debug lines into the Plugin and the OrIdentitySource from the
> model, but I can’t seem to track anything down.. The resulting org identity
> object seems valid.
> Running 4.0.1 with php 7.2.
> Thanks,
> John
> --
> John Daniels
> Principal Systems Engineer
> Children's Hospital of Philadelphia Research Institute

Archive powered by MHonArc 2.6.24.

Top of Page