Skip to Content.
Sympa Menu

oess-users - [oess-users] OESS with HP ProCurve 6600 Switch

Subject: oess-users

List archive

[oess-users] OESS with HP ProCurve 6600 Switch

Chronological Thread 
  • From: Grant Salk <>
  • To: "" <>, "" <>
  • Subject: [oess-users] OESS with HP ProCurve 6600 Switch
  • Date: Mon, 24 Aug 2015 19:42:24 +0000
  • Accept-language: en-US

Hi all,

I'm working on using OESS with an HP ProCurve 6600 switch.  I tried two different
attempts at getting a working VLAN circuit, both unsuccessful.  Here's a bit more information:

Attempt 1:

OESS discovered the HP switches and the links between the switches.  After
approval of the devices/links, I added the specific interfaces (hardware ports)
that are connected to hosts to a workgroup called "test."  I made sure to save
the appropriate configuration on all switches, and rebooted them all.  I did this to
make sure that each switch had no flows in its flow table.  I know this worked
(on one HP switch--"HP7") because I tried having one host ("host8") ping another ("host6")
on host8's connected interface (eth3) using "ping -I eth3 host6" and it resulted in
"Destination Host Unreachable."  I then tried to provision a VLAN circuit on
OESS between two hosts on one single HP switch.  In this case, it was between
host6 (interface/port 6) and host8 (interface/port 47) on HP7.

The circuit was successfully provisioned; however, host8 was still unable to
ping host6 (and vice versa).  This shows that the OESS VLAN circuit
is not provisioned/working properly.  Additionally, when on the "test"
workgroup and the recently-provisioned-VLAN is selected under the "Active
VLANS" tab, input/output data amounts are supposed to appear on a graph.
However, it continually says "Building... Data collection for this circuit is
building, one moment..." and nothing ever appears.  Occasionally, if I select a
button somewhere else on that page, the "Building... Data..." disappears and
an error pops up saying something along the lines of "Error fetching data".

Attempt 2:

Same configuration and set-up as Attempt 1, except that instead of provisioning a
VLAN circuit across two interfaces (hardware ports) on the same switch, I tried
to provision a VLAN circuit between two hosts across two connected switches.  Before
provisioning, I made sure that there was no connectivity between the hosts.

The circuit was NOT successfully provisioned.  A notice pops up saying,
"Error - Unable to provision circuit.  Please check your logs or contact your
server adminstrator for more information.  Circuit has been removed."  The only
log files I found related to OESS were supposed to be in /var/log/oess (but
this was non-existent) and in /etc/oess/logging.conf (and this proved to be not
helpful by my eyes, but I'm not sure what more experienced folks might say).

I don't know exactly what would cause these problems.  Could it simply be that these
problems are occurring because OESS isn't compatible with HP switches (according to
GlobalNOC's site)?

On a side note, what happens if I decommission a device or link?  Is it possible to recover a decommissioned device or link?

Thank you for your time.

Very respectfully,

  • [oess-users] OESS with HP ProCurve 6600 Switch, Grant Salk, 08/24/2015

Archive powered by MHonArc 2.6.16.

Top of Page