Skip to Content.
Sympa Menu

grouper-users - [grouper-users] vtldapPooling options seem to be ignored.

Subject: Grouper Users - Open Discussion List

List archive

[grouper-users] vtldapPooling options seem to be ignored.

Chronological Thread 
  • From: Jeffrey Crawford <>
  • To: Gouper Users List <>
  • Subject: [grouper-users] vtldapPooling options seem to be ignored.
  • Date: Wed, 9 Sep 2015 16:31:58 -0700

After having trouble with pooled connections. I tried to adjust the parameters by using the options provided by I'm pretty sure that at least the sources.xml referencing the file is ignoring those parameters.

I've tried setting edu.vt.middleware.ldap.pool.minPoolSize to "5" but I still only get three connections on startup. I've adjusted the edu.vt.middleware.ldap.pool.pruneTimerPeriod and edu.vt.middleware.ldap.pool.expirationTime but I never see the disconnect. at the theoretical maximum of two minutes. experationTime to 90 seconds and pruneTimerPeriod to 30.

We have a load balancer sitting between us and the multiple LDAP server backend, however if a connection is open and idle, the LB will drop the connection silently after about three minutes. However the vtldapPool defaults keep the connections open for a lot longer than the LB allows.


Both pilots and IT professionals require training and currency before charging into clouds!

Archive powered by MHonArc 2.6.16.

Top of Page