Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] Problem running usdu

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] Problem running usdu

Chronological Thread 
  • From: Peter DiCamillo <>
  • To: Chris Hyzer <>
  • Cc: "" <>
  • Subject: Re: [grouper-users] Problem running usdu
  • Date: Tue, 20 Nov 2012 23:25:18 -0500

I enabled debug level logging, but there was still nothing to directly indicate the cause. But the logging did show that the error occurred part of the way through a long list of query results, and I figured it out. More memory was allocated to java for the daily report than for gsh. When I increased the memory allocation for gsh to match, then it worked.


Chris Hyzer wrote:
Are there more logs you can send?


-----Original Message-----

On Behalf Of Peter DiCamillo
Sent: Tuesday, November 20, 2012 12:02 PM

Subject: [grouper-users] Problem running usdu

I'm having a problem with usdu. It appears to run ok as part of the daily report, and finds many unresolvable subjects. But when I run it using "bin/ -usdu -all" or "bin/ -usdu -all -delete" I get this error after a few minutes:

Problem in HibernateSession: HibernateSession: isNew: true, isReadonly: true,
grouperTransactionType: READONLY_NEW,
Exception in list: (class edu.internet2.middleware.grouper.Member),
ByHqlStatic, query: 'select distinct theMember from Member as theMember where
exists (select 1 from ImmediateMembershipEntry as theMembership where
theMembership.memberUuid = theMember.uuid) or exists (select 1 from
AttributeAssign as theAttributeAssign where theAttributeAssign.ownerMemberId
= theMember.uuid) ', cacheable: null, cacheRegion: null, tx type: null, tx
type: null

I want to run usdu from gsh in order to delete the subjects it found in the daily report. Any suggestions?


Archive powered by MHonArc 2.6.16.

Top of Page