Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] External user invitations no longer working

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] External user invitations no longer working

Chronological Thread 
  • From: Peter DiCamillo <>
  • To: Chris Hyzer <>
  • Cc: "" <>
  • Subject: Re: [grouper-users] External user invitations no longer working
  • Date: Mon, 05 Nov 2012 15:34:18 -0500

After those updates invitations are back to working normally. I also tested the "delete record" button, and that didn't cause any problems. Thanks for the quick fix!


Peter DiCamillo wrote:
I've been regularly updating the test system from the 2.1 branch, so a recent change could explain this. I'll update again and get back to you with the results.


Chris Hyzer wrote:
Im not sure it is related to deleting external users, but I do think there is a problem, introduced from the session change we have made recently for require-user-in-group.

I just committed some changes to: GuiSubject, GrouperUiUtils, GrouperUiFilter. Can you get the latest 2.1 branch or merge in these changes and try again?

We haven't officially released 2.1.3 so we can put these changes in there too...


-----Original Message-----
From: Peter DiCamillo [mailto:] Sent: Monday, November 05, 2012 9:09 AM
To: Chris Hyzer

Subject: Re: [grouper-users] External user invitations no longer working

I think I need to do more testing at this point to determine if the problem is in Grouper or somewhere else. I'll try to at least determine that, and write again if it appears to be in Grouper.


Peter DiCamillo wrote:
Thanks. I checked the tables, and grouper_ext_subj has no duplicate identifiers, and grouper_ext_subj_attr is empty. I also checked the invitations, and there are no duplicate invite_id values in grouper_ext_subj_invite_v.

The error happens at the time of the next invite, for any invite. Also, I get the same error if I make a change to the invite id in the link, so that the invite id should be invalid. It's as if Grouper is trying to log me in normally, rather than recognizing I'm trying to accept an invitation. It occurred to me that there may be a problem with the Apache or Tomcat configuration, but those weren't changed from when it was working.


On 11/4/12 10:38 PM, Chris Hyzer wrote:
Ok, I don't have the delete button enabled (default). I deleted myself on the demo server (v2.0), and it deleted the record in the table grouper_ext_subj. Then I registered again and it added a record to that table. I think if you look in that table and grouper_ext_subj_attr?, you should be able to see the dupes and delete one and you will be all set hopefully. I see that log message, but it is outdated at the time of the delete, not at the time of the next invite, right? Let me know if you see anything and I will keep looking...


-----Original Message-----
From: Peter DiCamillo
Sent: Sunday, November 04, 2012 3:20 PM
To: Chris Hyzer

Subject: Re: [grouper-users] External user invitations no longer working

That doesn't seem to be it. Today I tested using a different computer
than the one I had been using. I did this:

1. Login with my admin account and send an invitation to another account.
2. Quit from the browser.
3. Follow the link in the invitation mail, which launches the browser again.
4. Authenticate with the other account.

After the authentication is successful, I get the subject not found
error for the account I just logged-in as. This had been working fine,
right up until I tried used the delete credentials options last night.


On 11/4/12 4:50 AM, Chris Hyzer wrote:
I think you are signed on as a user who is not in the system anymore, right? Can you sign out or clear cookies or something and sign in as a user who exists and do another invite?


-----Original Message-----
From: [mailto:] On Behalf Of Peter DiCamillo
Sent: Saturday, November 03, 2012 11:56 PM

Subject: [grouper-users] External user invitations no longer working

I was doing some testing of external user invitations. At one point I
sent an invitation to an external account that was already registered
with Grouper. Then, in response to the invitation I clicked on the
delete button to delete that user's association with Grouper. My intent
was to reset that account as far as Grouper was concerned, so I could do
a test as if that account had never been used with Grouper. After that,
no external invitations are working, either to that user again, or to
other external users that had never been used previously with Grouper.
When I follow the link to accept an invitation, instead of getting the
screen for that, I get a "subject not found error". Here's the trace
from the log:

edu.internet2.middleware.subject.SubjectNotFoundException: subject not found: ,
Cant find subject from login id:

at edu.internet2.middleware.grouper.subj.SourcesXmlResolver.thereCanOnlyBeOne(
at edu.internet2.middleware.grouper.subj.SourcesXmlResolver.findByIdOrIdentifier(
at edu.internet2.middleware.grouper.subj.CachingResolver.findByIdOrIdentifier(
at edu.internet2.middleware.grouper.subj.ValidatingResolver.findByIdOrIdentifier(
at edu.internet2.middleware.grouper.SubjectFinder.findByIdOrIdentifier(
at edu.internet2.middleware.grouper.ui.GrouperUiFilter.retrieveSubjectLoggedIn(
at edu.internet2.middleware.grouper.ui.GrouperUiFilter.doFilter(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.ajp.AjpAprProcessor.process(
at org.apache.coyote.ajp.AjpAprProtocol$AjpConnectionHandler.process(
I never used the "delete" button in an invitation before, so I suspect
that has something to do with this. This seems very odd to me, because I
wouldn't expect the subject to be found before the invitation had been
accepted. Any ideas on how I can get it working again? This is not a
production system, so it's not urgent.


Archive powered by MHonArc 2.6.16.

Top of Page