Skip to Content.
Sympa Menu

grouper-users - RE: [grouper-users] Grouper 1.4.0 RC1: grouper-ws - SubjectNotFoundException on deployment

Subject: Grouper Users - Open Discussion List

List archive

RE: [grouper-users] Grouper 1.4.0 RC1: grouper-ws - SubjectNotFoundException on deployment

Chronological Thread 
  • From: Chris Hyzer <>
  • To: "" <>, Grouper Users Mailing List <>
  • Subject: RE: [grouper-users] Grouper 1.4.0 RC1: grouper-ws - SubjectNotFoundException on deployment
  • Date: Wed, 26 Nov 2008 09:17:03 -0500
  • Accept-language: en-US
  • Acceptlanguage: en-US

Thanks for pointing this out and for your patience.

Is this a tarring issue? (note I created a build script for
web services, can we use this from now on? See below)

Issue #1, the filename is .gz, not .tar.gz
Issue #2, I unzipped on windows with winzip, and it didn’t build correctly
(see attached screenshot, some source files weren’t named correctly in the
tar for some reason when using winzip)

I checked out from cvs and built, and it put subject.jar in the lib dir
(note, I had to adjust a entry in RC1, not in HEAD):


co -r GROUPER_WS_1_4_0_RC1 grouper-ws

change (in RC1, not in RC2+):
FROM: generated.client.project.dir=../grouper-ws-java-generated-client_HEAD
TO: generated.client.project.dir=../grouper-ws-java-generated-client

Build with ant, worked fine.


For the build (for grouper team), make sure you have this
in your ~/.bash_profile file:

export JAVA_HOME=/home/mchyzer/java
export ANT_HOME=/home/mchyzer/ant
export PATH=$JAVA_HOME/bin:$ANT_HOME/bin:/home/mchyzer/bin:$PATH

dist]$ HEAD

Note, for both binary builds, I made the output go to my home dir, and not
the /tmp dir anymore, since the /tmp dir doesn’t have that much space... it
will tell you where the output is, and you should have access to see it.

I did the grouperWs build, unzipped on unix and windows and it worked fine
(with subject.jar in lib dir)...

> -----Original Message-----
> From: Dr. Loris Bennett
> [mailto:]
> Sent: Wednesday, November 26, 2008 4:40 AM
> To: Grouper Users Mailing List
> Subject: [grouper-users] Grouper 1.4.0 RC1: grouper-ws -
> SubjectNotFoundException on deployment
> Hi,
> When I try to deploy the grouper-ws webapp, it fails to start with the
> following error:
> 26.11.2008 09:09:54 org.apache.catalina.core.StandardContext
> filterStart
> SCHWERWIEGEND: Exception starting filter Grouper service filter
> java.lang.NoClassDefFoundError:
> edu/internet2/middleware/subject/SubjectNotFoundException
> The problem seems to be that subject.jar is not included in the war
> file. A workaround is to copy subject.jar from lib/grouper to
> lib/custom.
> I assume that something goes wrong when ant constructs the set of jar
> files to copy to WEB-INF/lib. However, looking at the differences in
> build.xml for 1.3 and 1.4RC I can't see how the changes made would
> cause
> this problem, but then I am no ant expert. I am using ant 1.7.1.
> Regards
> Loris
> --
> Dr. Loris Bennett (Mr.)
> Freie Universität Berlin
> Zentraleinrichtung für Datenverarbeitung / Computer Center
> Compute & Media Service
> Fabeckstr. 32, Room 221
> D-14195 Berlin
> Tel ++49 30 838 51024
> Fax ++49 30 838 56721
> Email
> Web

Attachment: wsIssue.gif
Description: wsIssue.gif

Archive powered by MHonArc 2.6.16.

Top of Page