Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] ldappc + membership

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] ldappc + membership

Chronological Thread 
  • From: Graham Seaman <>
  • To: "" <>
  • Cc: Kathryn Huxtable <>
  • Subject: Re: [grouper-users] ldappc + membership
  • Date: Mon, 09 Jun 2008 10:31:35 +0100

Kathryn Huxtable wrote:
Graham, if you could insert the following lines after line 739 in and run it again I'd like to see the results. This is to be inserted after the e.printStackTrace() call in the catch clause where it's attempting to modify the attributes and failing.
OK, done.
I can only describe the behaviour I'm getting as erratic. Anyway, this is what happened so far:

1. Starting from the state described in my last email (with ldappc.xml using isMemberOf) I added your code and recompiled, then reran ldappc without making any other changes. The code ran without errors, no exceptions were generated, and ldapsearch showed the change had been made correctly; i.e. the isMemberOf attribute for the users concerned contained the value 'testy:ldap1', my first test group. I don't know why it has suddenly started to work ok when this setup failed on Friday.

2. I then used grouper to create a second group, 'testy:ldap2', and made the same users members of this group too. I ran ldappc, which gave no errors. However ldapsearch shows that rather than appending this group to the isMemberOf attribute, it had overwritten the original value in isMemberOf.

3. I then changed ldappc.xml to use eduPersonEntitlement rather than isMemberOf, expecting the existing value in this field - which is not managed by grouper - to be overwritten (the current value is urn:mace:InCommon:entitlement:common:1). This time ldappc threw an exception as before (plus your diagnostics): [LDAP: error code 20 - Attribute Or Value Exists]; remaining name 'cn=seamang,ou=flame users,dc=lse,dc=ac,dc=uk'
at com.sun.jndi.ldap.LdapCtx.mapErrorCode(
at com.sun.jndi.ldap.LdapCtx.processReturnCode(
at com.sun.jndi.ldap.LdapCtx.processReturnCode(
at com.sun.jndi.ldap.LdapCtx.c_modifyAttributes(
at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_modifyAttributes(
at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.modifyAttributes(
at com.sun.jndi.toolkit.ctx.PartialCompositeDirContext.modifyAttributes(
at edu.internet2.middleware.ldappc.GrouperProvisioner.updateSubject(
at edu.internet2.middleware.ldappc.GrouperProvisioner.performActualMembershipUpdates(
at edu.internet2.middleware.ldappc.GrouperProvisioner.provisionMemberships(
at edu.internet2.middleware.ldappc.GrouperProvisioner.provision(
at edu.internet2.middleware.ldappc.LdappcGrouperProvisioner.provisionGroups(
at edu.internet2.middleware.ldappc.Ldappc.main(
Printing ModItems array:
op = 1, id = objectClass
op = 2, id = eduPersonEntitlement

Re installing Fedora-DS on ubuntu: the wiki has a page on this;
See also
I haven't tried it on ubuntu, though: I am currently running it on CentOS and RHE, and have done a minimal install on debian etch
(following which seemd to go ok, but which I haven't tested in earnest yet.

Thanks for the help

Archive powered by MHonArc 2.6.16.

Top of Page