Skip to Content.
Sympa Menu

shibboleth-users - [Shib-Users] ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1

Subject: Shibboleth Users

List archive

[Shib-Users] ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1


Chronological Thread 
  • From: "Robert D. Krzyspiak" <>
  • To:
  • Subject: [Shib-Users] ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1
  • Date: Thu, 26 Aug 2010 10:38:29 -0400

Hi,

I am using IIS5 on a W2k server. Shibboleth installation v2.3.1 went through fine, however the Shibboleth ISAPI filter shows a red arrow with an Unknown priority and that it was not loaded. Tried adding this filter also directly to the default website as well as the direct website shibboleth is to be used on. The shibd.exe -check says the configuration is loadable. Neither the shibd.log or native.log show anything menacing as far as can be seen. The shibboleth install directory has full control to everyone. Also tried "tickling" the site by going to it locally through localhost or from the outside which supposefly sometimes loads the filter and this did not make a difference.

The Event Viewer has one added bit of info:
The description for Event ID ( 7701 ) in Source ( Shibboleth ISAPI Filter ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: Filter shut down...

and

The description for Event ID ( 2100 ) in Source ( Shibboleth ISAPI Filter ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: Filter failed to generate a random anti-spoofing key (if this is Windows 2000 set one manually)..

Maybe this is a common issue, but I did try looking around for this problem and did play around with poking around with some different settings. The current state is clean now, and I am not sure where to try from here. Any help or suggestions would be very much appreciated.

Thank you.

Rob




Archive powered by MHonArc 2.6.16.

Top of Page