Skip to Content.
Sympa Menu

ndt-dev - [ndt-dev] Comment on revision r955 in ndt

Subject: NDT-DEV email list created

List archive

[ndt-dev] Comment on revision r955 in ndt


Chronological Thread 
  • From:
  • To:
  • Subject: [ndt-dev] Comment on revision r955 in ndt
  • Date: Sat, 22 Feb 2014 12:14:04 +0000

Comment by
:

Line-by-line comments:

File: /branches/FlashIssue117/flash-client/src/GUI.as (r955)
===============================================================================

Line 329: if (TestResults.getErrMsg() != "") {
-------------------------------------------------------------------------------
Indentation non correct. Please, fix.
Line 330: _summaryResultText += "There were some errors during tests:<br>"
-------------------------------------------------------------------------------
I'd suggest to replace
"during tests"
with
"during the test"
because the previous line in the result tab says "NDT test run ... "
File: /branches/FlashIssue117/flash-client/src/TestResults.as (r955)
===============================================================================

Line 83: _errMsg += "<font color=\"#FE9A2E\"><b>" + msg + "</b></font>" + "\n";
-------------------------------------------------------------------------------
I suggest have all the formatting code in GUI.as.
Namely, I suggest the following changes:

in src/TestResults.as
public static function appendErrMsg(msg:String):void {
_errMsg += msg + "\n";
NDTUtils.callExternalFunction("appendErrors", msg);
appendDebugMsg(msg);
}

in src/GUI.as
if (TestResults.getErrMsg() != "") {
_summaryResultText += "There were some errors during the tests:<br>"
+ "<font color=\"#CC3333\"><b>" + TestResults.getErrMsg() + "</b></font>" + "\n";


Line 85: appendDebugMsg("<font color=\"#FE9A2E\"><b>" + msg + "</b></font>");
-------------------------------------------------------------------------------
#FE9A2E is very difficult to read.
I suggest to use #CC3333 instead.

For more information:
https://code.google.com/p/ndt/source/detail?r=955


  • [ndt-dev] Comment on revision r955 in ndt, ndt, 02/22/2014

Archive powered by MHonArc 2.6.16.

Top of Page