Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] [Ext] Re: pspng ldapSearchResultPagingSize doesn't seem to do anything

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] [Ext] Re: pspng ldapSearchResultPagingSize doesn't seem to do anything

Chronological Thread 
  • From: "Crawford, Jeffrey" <>
  • To: Daniel Burtenshaw <>, Greg Haverkamp <>
  • Cc: Grouper-Users <>, Jeffrey Williams <>
  • Subject: Re: [grouper-users] [Ext] Re: pspng ldapSearchResultPagingSize doesn't seem to do anything
  • Date: Thu, 29 Aug 2019 20:12:48 +0000
  • Arc-authentication-results: i=1; 1; spf=pass; dmarc=pass action=none; dkim=pass; arc=none
  • Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed;; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-SenderADCheck; bh=M9dES8DV0QQGPk2E3488Mg6rn3yqN+crECdPvKn3fSo=; b=jJXVwt+0o95I3E0l9O8RMDwKpEeoYuVUtmDJqRMte2NZPZsCE56BhHO86R1KVD84Tf7hWmuph18bMdbiUZyRbcKt8xqKHze6FY6xr8rmCCDldmQxsN/CzMPdyWYpjVE8Z3FBKRDXnlkmQg3g5nxiX827SptJCzq/90UhwOSr3bu2zjY/hW8n1VM3o/4GOJC1t7/H+ttNfnvGQK52VtCLwBcBWFLsB/sO2TFsdQgXT+3nz+uGWR9cGwjw1hCNwsbQS822/4VNcwlAA6O6/DwAgKG+f/8jNoS4NYQ/kHu8iyWgZlDBoNkMoG7blCZkE7CH+4xZYRitKUI80NjV6YyzYQ==
  • Arc-seal: i=1; a=rsa-sha256; s=arcselector9901;; cv=none; b=IDCUguMouBAAxhgr37ZmwQgyF2wHj+T6nM7Fiape9jRfCGgFLUBJkDUyamLhaCtQYl3B9bLKAmnprnetITAk/qo9R0JrEQ6f4IKe9Lce5rMd4yJFGT5eFdPGm+wrln98ow5bHJG/AhxRDm/3I/KZO+DYH6ZDsbM2Tdd0SrYttLlQFoqmFbBYZamY6M9+RhGhMaGLVHvmrxS9wBU56ZYmOH/CQqmlYOAT/S+t+nKE6tu972qaRQxeAMdu7FS7syjCF4LoQlm45N5aZBKTZvwiKeI+jAnV7F7h+FSXv88bFkY0KLgObiljSETfDZZJfpklJsHZwGHIMCZN52K2Sx46lA==

Humm, I tried that too, seems to have been ignored by pspng, also on this page it’s listed as an option:


but it seems to have a default so I wonder if the code is “resetting” it.


From: Daniel Burtenshaw <>
Date: Thursday, August 29, 2019 at 1:06 PM
To: Greg Haverkamp <>, "Crawford, Jeffrey" <>
Cc: Grouper Users <>, Jeffrey Williams <>
Subject: RE: [Ext] Re: [grouper-users] pspng ldapSearchResultPagingSize doesn't seem to do anything


I think that Greg is correct, I’ve used it with success in the ldap connection settings rather than the changelog.consumer settings, so something like:


                ldap.personLdap.pagedResultsSize = 1000


should work.


From: <> On Behalf Of Greg Haverkamp
Sent: Thursday, August 29, 2019 1:48 PM
To: Crawford, Jeffrey <>
Cc: Grouper-Users <>; Jeffrey Williams <>
Subject: [Ext] Re: [grouper-users] pspng ldapSearchResultPagingSize doesn't seem to do anything


WARNING: Stop. Think. Read. This is an external email.

I think you want it in your personLdap configuration.  Unless I botched the search, “ldapSearchResultPagingSize” doesn’t exist anywhere in the Grouper repo (in master).


However, it does appear to pull the searchResultPagingSize in

  public int getSearchResultPagingSize() {
    Object searchResultPagingSize = getLdaptiveProperties().get("org.ldaptive.searchResultPagingSize");
    return GrouperUtil.intValue(searchResultPagingSize, searchResultPagingSize_default_value);


And getLdaptiveProperties should pull that in from your ldap.personLdap.* properties.





On Thu, Aug 29, 2019 at 11:42 AM Crawford, Jeffrey <> wrote:

The following is what we have, but it’s pretty simple:


ldap.personLdap.url = "ldaps://

ldap.personLdap.user = uid=ldappc, dc=some, dc=path

ldap.personLdap.pass = /opt/grpr/grouper.apiBinary/conf/encryptedLDAP.pass

ldap.personLdap.tls = false

ldap.personLdap.countLimit = 1000

ldap.personLdap.timeLimit = 5000


From: Jeffrey Williams <>
Date: Thursday, August 29, 2019 at 9:51 AM
To: "Crawford, Jeffrey" <>
Cc: Grouper Users <>
Subject: Re: [grouper-users] pspng ldapSearchResultPagingSize doesn't seem to do anything


Can we see your personLdap config?

On Thu, Aug 29, 2019, 11:59 AM Crawford, Jeffrey <> wrote:

I have the following entry in our pspng config, I noticed that on FullSyncer it pages at 100 elements, our system performs better at 1000 so I tried setting the page size, but the LDAP logs still show that it’s paging at 100.


Am I using the parameter correctly?


changeLog.consumer.pspng_entitlement.class = edu.internet2.middleware.grouper.pspng.PspChangelogConsumerShim

changeLog.consumer.pspng_entitlement.type = edu.internet2.middleware.grouper.pspng.LdapAttributeProvisioner

changeLog.consumer.pspng_entitlement.quartzCron = 0 * * * * ?

changeLog.consumer.pspng_entitlement.retryOnError = true

changeLog.consumer.pspng_entitlement.ldapPoolName = personLdap

changeLog.consumer.pspng_entitlement.provisionedAttributeName = eduPersonEntitlement

changeLog.consumer.pspng_entitlement.provisionedAttributeValueFormat =${"^ucla(?::org)?(.*:)app:(.*)$", "$1$2").replaceFirst(":entitlement:",":")}

changeLog.consumer.pspng_entitlement.userSearchBaseDn = ou=people,dc=ucla,dc=edu

changeLog.consumer.pspng_entitlement.userSearchFilter = uclaPPID=${}

changeLog.consumer.pspng_entitlement.ldapSearchResultPagingSize = 1000

changeLog.consumer.pspng_entitlement.userSearchAttributes = dn,cn,uid,mail,samAccountName,uidNumber,objectClass,uclaPPID



Jeffrey Crawford


Archive powered by MHonArc 2.6.19.

Top of Page