Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] upgrading to 2.4

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] upgrading to 2.4

Chronological Thread 
  • From: Ben Beecher <>
  • To: "Hyzer, Chris" <>
  • Cc: " Mailing List" <>
  • Subject: Re: [grouper-users] upgrading to 2.4
  • Date: Mon, 15 Apr 2019 16:09:22 -0400

Hi Chris,
I upgraded those modules again with the full patch set and it's working now. Thanks for your help.
After upgrading to Grouper 2.4 the CAS authentication is no longer working. I can only use Basic Auth to log in to Grouper 2.4. We have been using the Yale CAS Client (yale-cas-auth) following these instructions

I double checked the updates to these files

Everything looks ok there, sources.xml was replaced by I am not sure if I need to rebuild the war file as per the instructions. When I try to rebuild I get some errors:

$ ant war
Buildfile: /var/grouper/installGrouper2.3/grouper.ui-2.3.0/build.xml

    [mkdir] Created dir: /var/grouper/installGrouper2.3/grouper.ui-2.3.0/temp/jarBin
    [javac] /var/grouper/installGrouper2.3/grouper.ui-2.3.0/build.xml:452: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 324 source files to /var/grouper/installGrouper2.3/grouper.ui-2.3.0/temp/jarBin
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.5
    [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
    [javac] /var/grouper/installGrouper2.3/grouper.ui-2.3.0/java/src/edu/internet2/middleware/grouper/j2ee/ error: GenericServletResponseWrapper is not abstract and does not override abstract method getHeaderNames() in HttpServletResponse
    [javac] public class GenericServletResponseWrapper extends ServletResponseWrapper implements HttpServletResponse {
    [javac]        ^
    [javac] /var/grouper/installGrouper2.3/grouper.ui-2.3.0/java/src/edu/internet2/middleware/grouper/ui/ error: CaptureServletOutputStream is not abstract and does not override abstract method setWriteListener(WriteListener) in ServletOutputStream
    [javac] public class CaptureServletOutputStream extends ServletOutputStream {
    [javac]        ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 2 errors
    [javac] 4 warnings

Any suggestions?

On Wed, Apr 3, 2019 at 9:00 AM Hyzer, Chris <> wrote:

Are you sure you pointed the upgrader to the right spot?  I think the WS might live somewhere else?  look in apache config and see where it is linking to


From: Ben Beecher <>
Sent: Tuesday, April 02, 2019 4:05 PM
To: Hyzer, Chris <>
Cc: Mailing List <>; Ben Beecher <>
Subject: Re: [grouper-users] upgrading to 2.4


Hi Chris,

I was able to get past that error by copying the old patches to /var/grouper/installGrouper2.3/tarballs/patches/

I have another question for you.

I used the Grouper upgrader to upgrade the api and ui modules. While upgrading the ws it reverted all patches and then it got this error:


> Upgrading WS jars

> Exception in thread "main" java.lang.RuntimeException: Why does jar directory not exist?

> /var/grouper/installGrouper2.3/tarballs/


I created the last two subdirectories manually (WEB-INF/lib) and then I ran the upgrader again. I got a different error this time:


Upgrading WS jars

Upgraded 0 jar files from: /var/grouper/installGrouper2.3/tarballs/

  to: /var/grouper/installGrouper2.3/



Upgrading WS files

Upgrading files from: /var/grouper/installGrouper2.3/tarballs/

  to: /var/grouper/installGrouper2.3/

  ignoring paths: WEB-INF/bin/, WEB-INF/bin/gsh.bat, WEB-INF/lib, WEB-INF/bin/gsh, WEB-INF/web.xml, WEB-INF/classes

Compared 0 files and found 0 adds and 0 updates

Backing up: /var/grouper/installGrouper2.3/ to: /var/grouper/installGrouper2.3/tarballs/bak_WS_2019_03_26_21_06_36_798/WEB-INF/bin/gsh.bat

Copying new file: /var/grouper/installGrouper2.3/tarballs/ to: /var/grouper/installGrouper2.3/

Exception in thread "main" java.lang.RuntimeException: Source '/var/grouper/installGrouper2.3/tarballs/' does not exist

                at edu.internet2.middleware.grouperInstaller.util.GrouperInstallerUtils.copyFile(

                at edu.internet2.middleware.grouperInstaller.GrouperInstaller.backupAndCopyFile(

        at edu.internet2.middleware.grouperInstaller.GrouperInstaller.upgradeWs(

        at edu.internet2.middleware.grouperInstaller.GrouperInstaller.access$5800(

                at edu.internet2.middleware.grouperInstaller.GrouperInstaller$AppToUpgrade$4.upgradeApp(

                at edu.internet2.middleware.grouperInstaller.GrouperInstaller.mainUpgradeLogic(

        at edu.internet2.middleware.grouperInstaller.GrouperInstaller.access$600(

        at edu.internet2.middleware.grouperInstaller.GrouperInstaller$GrouperInstallerMainFunction$3.logic(

                at edu.internet2.middleware.grouperInstaller.GrouperInstaller.mainLogic(

                at edu.internet2.middleware.grouperInstaller.GrouperInstaller.main(

Caused by: Source '/var/grouper/installGrouper2.3/tarballs/' does not exist

        at edu.internet2.middleware.grouperInstaller.util.GrouperInstallerUtils.copyFile(

                ... 9 more



I see the new version of gsh.bat in the ui directory so perhaps I don't need to update the gsh.bat in the ws directory.


$ ls -l /var/grouper/installGrouper2.3/grouper.ui-2.3.0/dist/grouper/WEB-INF/bin/gsh.bat

-rwxr-xr-x. 1 idmserv idmserv 4174 Mar 26 20:46 /var/grouper/installGrouper2.3/grouper.ui-2.3.0/dist/grouper/WEB-INF/bin/gsh.bat



On Wed, Mar 20, 2019 at 9:39 AM Hyzer, Chris <> wrote:

Ben, I think you need to download the 2.4 ALL zip, which you did, but you also need the 2.3 ALL zip, can you download that to so the file not found goes away and see if it works?


From: <> On Behalf Of Hyzer, Chris
Sent: Tuesday, March 19, 2019 11:35 PM
To: Ben Beecher <>; Mailing List <>
Subject: RE: [grouper-users] upgrading to 2.4


Ugh, maybe copy the dir you are upgrading to an internet machine, upgrade, and copy back… sorry, I entered a jira…





From: <> On Behalf Of Ben Beecher
Sent: Tuesday, March 19, 2019 4:00 PM
To: Mailing List <>
Subject: [grouper-users] upgrading to 2.4


(1) I am trying to upgrade from version 2.3 to version 2.4. The Grouper upgrader wants to upgrade in place (not into a new directory) so do I need to rename the directory after the upgrade is complete? The current directory name is



and I think the new name should be




(2) I get an error during the upgrade process. My server is on a secure network so it can't download patch files from the internet. I downloaded the tar file which contains all patches


I uncompressed and extracted the contents to this directory



I created a properties file that points to the new directory


$ cat /var/grouper/installGrouper2.3/ 

download.server.url = "/var/grouper/grouper.all-2.4.0


# default version to install

grouper.version = 2.4.0


I ran the installer with the "upgrade" option but it gets an error when it tries to access one of the 2.3 patch files. It's looking for a 2.3 patch file in the 2.4 directory that was recently downloaded.



Gather upgrade information


Enter in a Grouper temp directory to download tarballs (note: better if no spaces or special chars) [/var/grouper/installGrouper2.3/tarballs]: /tmp/grouper/patches

You need to revert all patches to upgrade


################ Checking patch grouper_v2_3_0_api_patch_88

Patch: grouper_v2_3_0_api_patch_88: was applied on: 2018/02/08 16:05:53


Error connecting to URL: /var/grouper/grouper.all-2.4.0/release/2.3.0/patches/grouper_v2_3_0_api_patch_88.tar.gz

Exception in thread "main" java.lang.RuntimeException: Error connecting to URL: /var/grouper/grouper.all-2.4.0/release/2.3.0/patches/grouper_v2_3_0_api_patch_88.tar.gz,


I have attached the session log to this message.




Archive powered by MHonArc 2.6.19.

Top of Page