Subject: Grouper Users - Open Discussion List
- From: Shilen Patel <>
- To: David Langenberg <>, "William G. Thompson, Jr." <>
- Cc: "" <>
- Subject: Re: [grouper-users] Groovy update and Java 7
- Date: Fri, 17 Nov 2017 12:39:43 +0000
- Accept-language: en-US
- Authentication-results: oit.duke.edu; spf=none
- Spamdiagnosticmetadata: NSPM
- Spamdiagnosticoutput: 1:99
Thanks for the feedback. We discussed this on the dev call this week and decided to add a check on the patch to just revert to the legacy gsh if you’re using Java 1.6.
I’d say if you’re issuing a potentially breaking patch that it warrants a full release. I’ll leave it up to you about calling this 2.4 or 2.3.1, but IMO if the version of the software I installed supported a specific dependency’s major version and now you’re saying I need to upgrade that dependency, then it’s no longer a routine patch.
Asst Director, Identity Management
The University of Chicago
Lafayette has no objection to requiring java 1.7 (no longer publicly supported) or higher for this patch. Though I must admit we do not keep up with the Grouper patches, unless there's a security issue. And even there, I think we'd be more comfortable with packaged security release.
I think I understand the rationale for the patches approach (faster updates), but it makes me wonder how many deployments are simply waiting for those to be rolled up into a proper release. We are currently on Grouper 2.2 and waiting for Grouper 2.4.
Also given the JDK lifecycle it seems prudent to require at least java 1.8 (end of public support September 2018) for the 2.4 release. That said it, I think it would also be reasonable to only test/support starting with java 1.9 depending on the timing of the release.
On Fri, Nov 10, 2017 at 8:42 AM, Shilen Patel <> wrote:
- [grouper-users] Groovy update and Java 7, Shilen Patel, 11/10/2017
Archive powered by MHonArc 2.6.19.