Skip to Content.
Sympa Menu

grouper-users - Re: [grouper-users] PSPNG fullSync error on group cleanup

Subject: Grouper Users - Open Discussion List

List archive

Re: [grouper-users] PSPNG fullSync error on group cleanup

Chronological Thread 
  • From: Paul Engle <>
  • To: Michael R Gettes <>
  • Cc:
  • Subject: Re: [grouper-users] PSPNG fullSync error on group cleanup
  • Date: Mon, 27 Feb 2017 16:12:55 -0600
  • Ironport-phdr: 9a23:PX1c9hOTygamuzsMfTcl6mtUPXoX/o7sNwtQ0KIMzox0Lfr4rarrMEGX3/hxlliBBdydsKMZzbCI+Pm9BiQp2tWoiDg6aptCVhsI2409vjcLJ4q7M3D9N+PgdCcgHc5PBxdP9nC/NlVJSo6lPwWB6nK94iQPFRrhKAF7Ovr6GpLIj8Swyuu+54Dfbx9GiTe5Yb5+Ngu6oATeusULgYZvKLs6xwfUrHdPZ+lY335jK0iJnxb76Mew/Zpj/DpVtvk86cNOUrj0crohQ7BAAzsoL2465MvwtRneVgSP/WcTUn8XkhVTHQfI6gzxU4rrvSv7sup93zSaPdHzQLspVzmu87tnRRn1gyoBKjU38nzYitZogaxGvhyhqRxxzY3abo6bO/VxfL/Sc9wBSGpdXctcTTBNDp+yYoYNCecKIOZWr5P6p1sLtRawHxOjBP7ryjRViXH226I60+A/Hgrb2wEgB8wBsHLbrNXxKqgfSvq1zKjUwjrddf9Zxyry6JXRfx0nvPqCU7Vwcc/LxkkuEQPIlkmQqYz/PzyLzOsCrnKX7/B9VeKpjWMstgJ/oiC3y8sxlIXEhZgZx1/a+Slj3oo5OcC0RFRmbdK4DZdcrzyWO5V1T884TGxkpjw2xqMatZKmZiQG1okryhjCYPKdaYeI+AjsVOOJLDd4mn1lfLW/ig6q8Ui41OHwTNO00FdWoSVbiNXDqG0C1wHL5siGTPty4Fuh1C6S2wzN6exIO085mbTBJ5I/3rI8i4AfvVnfEiPrgEn2ibWZdkQg+uim8eTnZbDmq4eEN4BqjAH+PaAuldKkDOQiMwgBQ3aU9f6i27L+4E31WK9KgeEukqnFrJDaItwWpqGjAw9Sz4Yj8wiwDy2/3NQFhnkIMkhFeAmcgojtOlHOO+z4Deyhj1i2kTdrwezGMaP7ApXLMHfDjKntcaxj5EFB1QpghexYsrdVAbEILfa7YAfeucDEAwRxZwmuzL2/IM1my8UTVX/ZUYGDN6aHiVaV4qoCJeaIacdBoDv7JPwoz+TvhnJ/lFMAK/r6laALYWy1S6w1a36SZmDh148M

Yeah, I'd noticed the lack of accurate timings for a full sync. That's
what led me to this. Now that I have a config I can mostly live with, I
wanted to see how long a full run would take on all the stems that are
currently being provisioned. I was excited when the grouper_loader_log
seemed to indicate that the job finished in an hour or so. Less so once
I looked at the log and realized it was actually still running its
worker threads... :)

I'm going to take a guess and say that the check was maybe supposed to
be against cache size, not batch size. That seems more reasonable to me.


On 2/27/2017 4:04 PM, Michael R Gettes wrote:
> Yep, I saw this too. There also doesn’t seem to be an indicator in the log
> of start and stop of the fullsync (yes, you can consult the
> grouper_loader_log as well). I thought leaving the error there for now cuz
> it easily shows when the fullsync is finished :-) While this is humorous
> to me, for now, the error is useful.
> /mrg
>> On Feb 27, 2017, at 5:00 PM, Paul Engle
>> <>
>> wrote:
>> Me again, still kicking the PSPNG tires. I seem to have hit another snag
>> once I tried to ramp up my testing.
>> I have an LdapGroupProvisioner configured with grouperIsAuthoritative
>> set to true. It was working fine in my test stem that has a whopping 12
>> groups in it. Once I tried to attach the provisioner to a larger stem
>> however, I started to hit an error during group cleanup saying there
>> were too many groups to fetch.
>> Poking around the code, it seems to be generated by the
>> fetchTargetSystemGroups call when the number of groups in the
>> provisioning item is larger than groupSearch_batchSize. I confirmed that
>> by going back to just my test stem and dialing down the batch size to
>> 10. Sure enough, I get the same error now. Stack trace below:
>> 2017-02-27 15:21:52,500: [pspng_groupOfUniqueNames-FullSync] ERROR
>> FullSyncProvisioner.processGroupCleanup(356) - -
>> pspng_groupOfUniqueNames: Problem doing group cleanup
>> java.lang.IllegalArgumentException:
>> LdapGroupProvisioner.fetchTargetSystemGroups: invoked with too many
>> groups to fetch
>> at
>> edu.internet2.middleware.grouper.pspng.LdapGroupProvisioner.fetchTargetSystemGroups(
>> at
>> edu.internet2.middleware.grouper.pspng.Provisioner.doFullSync_cleanupExtraGroups(
>> at
>> edu.internet2.middleware.grouper.pspng.FullSyncProvisioner.processGroupCleanup(
>> at
>> edu.internet2.middleware.grouper.pspng.FullSyncProvisioner.thread_manageFullSyncProcessing(
>> at
>> edu.internet2.middleware.grouper.pspng.FullSyncProvisioner$
>> at
>> The groupSearch_batchSize defaults to 50. It doesn't seem right to bump
>> the batch size up to be greater than my total number of groups in any
>> given provisioning item, which can number in the thousands.
>> Has anyone else seen this?
>> -paul
>> --
>> Paul Engle
>> Office of Information Technology
>> 713-348-4702

Paul Engle
Office of Information Technology


Archive powered by MHonArc 2.6.19.

Top of Page