Skip to Content.
Sympa Menu

grouper-users - [grouper-users] RE: Using Grouper API in a maven project

Subject: Grouper Users - Open Discussion List

List archive

[grouper-users] RE: Using Grouper API in a maven project

Chronological Thread 
  • From: "Hyzer, Chris" <>
  • To: "Nakandala, Supun Chathuranga" <>, "" <>
  • Subject: [grouper-users] RE: Using Grouper API in a maven project
  • Date: Thu, 16 Jun 2016 20:48:29 +0000
  • Accept-language: en-US
  • Authentication-results: spf=none (sender IP is ) ;
  • Spamdiagnosticmetadata: NSPM
  • Spamdiagnosticoutput: 1:99

You can have a copy of the API binary with all same config files outside of your app.  And you should be able to init the database, have you done this yet?  (from the bin dir of the api binary)


gsh -registry -runscript


just checking… J






From: [mailto:] On Behalf Of Nakandala, Supun Chathuranga
Sent: Thursday, June 16, 2016 3:50 PM
Subject: [grouper-dev] Using Grouper API in a maven project


Hi Devs,


I trying to create a project which directly interacts with the Grouper Java API. The project is a maven project and I have added the following dependency.



I also copied the files inside the conf directory in the binary distribution into resources directory in the project and configured the correct database connections in the hibernate properties file. Also using the gsh I initialized the database.


But when I tried to run simple example code provided in the API.txt document I get the following error



Grouper warning: cannot find class com.thoughtworks.xstream.alias.CannotResolveClassException, perhaps you are missing jar: xstream.jar

Grouper error: grouper versions do not match, GrouperVersion.class: 2.3.0, null, manifest: null

Exception in thread "main" java.lang.NullPointerException

at edu.internet2.middleware.grouper.GrouperSourceAdapter$2.callback(

Disconnected from the target VM, address: '', transport: 'socket'

at edu.internet2.middleware.grouper.GrouperSession.callbackGrouperSession(

at edu.internet2.middleware.grouper.GrouperSourceAdapter.getSubjectsByIds(

at edu.internet2.middleware.grouper.GrouperSourceAdapter.getSubject(

at edu.internet2.middleware.grouper.subj.SourcesXmlResolver$1.callLogic(

at edu.internet2.middleware.grouper.subj.SourcesXmlResolver$1.callLogic(

at edu.internet2.middleware.grouper.subj.SourcesXmlResolver$

at edu.internet2.middleware.grouper.subj.SourcesXmlResolver.executeCallables(

at edu.internet2.middleware.grouper.subj.SourcesXmlResolver.find(

at edu.internet2.middleware.grouper.subj.CachingResolver.find(

at edu.internet2.middleware.grouper.subj.ValidatingResolver.find(

at edu.internet2.middleware.grouper.SubjectFinder.findById(

at edu.internet2.middleware.grouper.SubjectFinder.findById(

at org.apache.airavata.groupmanager.Main.main(


After Googling for the exception message I found this grouper email thread [] which is discussing the same issue. There is an open issue for this and I tried to manually copy this file into my project to overcome the issue. But I cannot find the misc/ file in the API binary distribution.


Where can I get this file? Or else your help on how to fix this issue is highly appreciated.





  • [grouper-users] RE: Using Grouper API in a maven project, Hyzer, Chris, 06/16/2016

Archive powered by MHonArc 2.6.16.

Top of Page