Skip to Content.
Sympa Menu

grouper-users - [grouper-users] RE: Broke my loader job

Subject: Grouper Users - Open Discussion List

List archive

[grouper-users] RE: Broke my loader job

Chronological Thread 
  • From: Chris Hyzer <>
  • To: "Bryan E. Wooten" <>, "" <>
  • Subject: [grouper-users] RE: Broke my loader job
  • Date: Mon, 24 Mar 2014 20:07:59 +0000
  • Accept-language: en-US

Mmmm, keep your views in version control?  J


Basically to troubleshoot this, you need to be able to resolve the entries in the subject API.  (e.g. in GSH)


It looks like you are using group name, which is the subject_identifier, not the subject_id, so maybe you just need to change the column name of the query (and/or the view column name)





From: [mailto:] On Behalf Of Bryan E. Wooten
Sent: Monday, March 24, 2014 4:04 PM
Subject: [grouper-users] Broke my loader job


Well this is embarrassing. I had 3 loader jobs that were working perfectly, but then I went and accidently over wrote one of my views.


So the 1st 2 jobs created course in enrollments and instructors. The 3rd job created an all group whose members were the 1st 2 groups. I broke the 3rd job.


My query looks like this:


select group_name, subject_id, 'g:gsa' from UUIDM.UU_IDM_COURSES_ALL


Now I get this error:


2014-03-24 13:12:03,930: [main] ERROR GrouperLoaderResultset$Row.getSubject(1197) -  - Problem with subjectId: students, subjectSourceId: , in jobName: uofu:campus:courses:currTerm:SB:PSYCH:PSY:Quantitative Methds II:5510:001:all

edu.internet2.middleware.subject.SubjectNotFoundException: subject not found: students


I’ve tried changing the results of the view so that “students” looks like the fully qualified group name (uofu:campus:courses:currTerm:SB:PSYCH:PSY:Quantitative Methds II:5510:001:students), but I get the same error.


I guess I’ve broken how to create loader jobs that have groups as members and regular people. Mondays….


Insight appreciated,



Archive powered by MHonArc 2.6.16.

Top of Page