Skip to Content.
Sympa Menu

grouper-dev - [grouper-dev] Unique group extension

Subject: Grouper Developers Forum

List archive

[grouper-dev] Unique group extension

Chronological Thread 
  • From: Gagné Sébastien <>
  • To: <>
  • Subject: [grouper-dev] Unique group extension
  • Date: Fri, 30 Mar 2012 10:58:22 -0400

Hello again,

Some time ago I asked about having unique group extension. Chris replied with a very helpful group hook and all was working fine with Grouper 2.0.1. Since then I installed Grouper 2.1 and the hook doesn’t work anymore. I suspect it’s because of the hibernate update, but wanted to confirm the behaviour first before doing a new hook.


Basically, the hook executed this query ["select count(g) from Group as g where g.extensionDb = :theExtension"] and checked if it returned anything [if count>0 throw exception]


It worked before the update, but now it always fails, even with a fresh database. I checked the database and GROUPER_GROUPS contains only one entry for the sysadmingroup.


To check what was returned, I added the output of this query in the error message : "select g from Group as g where g.extensionDb = :theExtension".


I tried to add the group with the ID “UdeM:test” I got this as the query content : name=UdeM:test,uuid=22c78379869e43e28a88f4e54826bafb. I rechecked the database and there is still only one group.


Any lead on what might cause this ? Does the hooks work differently ? Does it do a temporary add in the groups before the save in the database ?


Thank you


Sébastien Gagné,     | Analyste en informatique

514-343-6111 x3384| Université de Montréal,

                     | Pavillon Roger-Gaudry, local X-100-11


Archive powered by MHonArc 2.6.16.

Top of Page